3.0.2 slow when debugging

Bug reports.
Pixi6s
Posts: 92
Joined: Tue Jun 28, 2011 8:57 pm

3.0.2 slow when debugging

Post by Pixi6s » Thu Jun 30, 2011 8:04 pm

I am using Windows 7 with all the updates. I am using Ranorex 3.0.2. When I am debugging, Ranorex moves very slow. For example, when it hits my break point, it takes several seconds before I am able to move the mouse pointer or advance to the next line via F10. Is this something you guys are looking to fix up? :)

User avatar
sdaly
Posts: 238
Joined: Mon May 10, 2010 11:04 am
Location: Dundee, Scotland

Re: 3.0.2 slow when debugging

Post by sdaly » Thu Jun 30, 2011 10:42 pm

Do you use the features in Studio? If not then try using the standard version of SharpDevelop or Visual Studio and you will notice a performance difference!

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: 3.0.2 slow when debugging

Post by Support Team » Fri Jul 01, 2011 8:56 am

Hi,

Did you try to disable the Abort Key in the program.cs? This could be one possible reason, why it is slow during debugging. So please try to disable or comment out this line of code and retry to debug your code.

Regards,
Peter
Ranorex Team
.
Image

Pixi6s
Posts: 92
Joined: Tue Jun 28, 2011 8:57 pm

Re: 3.0.2 slow when debugging

Post by Pixi6s » Tue Jul 05, 2011 7:38 pm

Support Team wrote: Did you try to disable the Abort Key in the program.cs? This could be one possible reason, why it is slow during debugging. So please try to disable or comment out this line of code and retry to debug your code.
Keyboard.AbortKey = System.Windows.Forms.Keys.Pause;

I commented out the line above and it did not help. Was there more than this one line?

This continuing to happen in 3.0.3, it is taking literally 5 seconds before I can move my mouse pointer.
Thanks
Last edited by Pixi6s on Tue Jul 05, 2011 7:46 pm, edited 2 times in total.

Pixi6s
Posts: 92
Joined: Tue Jun 28, 2011 8:57 pm

Re: 3.0.2 slow when debugging

Post by Pixi6s » Tue Jul 05, 2011 7:40 pm

sdaly wrote:Do you use the features in Studio? If not then try using the standard version of SharpDevelop or Visual Studio and you will notice a performance difference!
I'm am new to Ranorex and the Visual Studio. I just started at a new company. :D What would you suggest for a performance increase? I do have Visual Studio 10. Also note that I do currently use a mix of recorded modules as well as user code modules.

Thanks

Pixi6s
Posts: 92
Joined: Tue Jun 28, 2011 8:57 pm

Re: 3.0.2 slow when debugging

Post by Pixi6s » Wed Jul 06, 2011 2:46 pm

Hello Support Team,

This is ridiculousness. Is this really not a standard problem with 3.0? My co-worker didn't have this issue with 2.x but is having the same issue I am with vary different code (pure user code instead of mostly recording mod).

I really need this pause to go away its frustrating. :|
Thanks

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: 3.0.2 slow when debugging

Post by Support Team » Wed Jul 06, 2011 3:13 pm

Hi,

As far as we know, this problem occurs only if the following two conditions are true:
  • The "LowLevelHooksTimeout" registry key is set (done by the Microsoft Visual Studio 2010 setup)
  • The Ranorex.Mouse.AbortKey is set or the Ranorex ProgressDialog is shown (default setting when running a test suite or recording)
Unfortunately, we have not found a solution other then either removing the "LowLevelHooksTimeout" or disabling both the AbortKey and ProgressDialog, yet.

For removing the "LowLevelHooksTimeout" key, please search your registry for a key with name "LowLevelHooksTimeout" and delete it. As far as we know, this registry key is not needed by Visual Studio or re-added if it is needed.

Regards,
Peter
Ranorex Team
.
Image

Pixi6s
Posts: 92
Joined: Tue Jun 28, 2011 8:57 pm

Re: 3.0.2 slow when debugging

Post by Pixi6s » Wed Jul 06, 2011 8:55 pm

Looks like turning off the progress dialog did it for me. That is a useful little guy, I'd like to request a fix for that.

To clarify, it did appear that just my mouse pointer was held up for 5 seconds, I was able to type (tab, ect).

For others, see the following lesson to turn off the progress dialog.
http://www.ranorex.com/support/user-gui ... suite.html

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: 3.0.2 slow when debugging

Post by Support Team » Thu Jul 07, 2011 8:56 am

Hi,
Pixi6s wrote:Looks like turning off the progress dialog did it for me. That is a useful little guy, I'd like to request a fix for that.

If you delete the key I provided you above, then the timeout is gone even when you use the ProgressDialog. This key is set to exactly 5000ms (5 seconds) and therefore Ranorex waits for this 5 seconds. Did you try to delete the key and did you try to debug with the Progress Dialog? I would suggest you to try this, because as you said, this little guy is very useful. :)

Regards,
Peter
Ranorex Team
.
Image

Pixi6s
Posts: 92
Joined: Tue Jun 28, 2011 8:57 pm

Re: 3.0.2 slow when debugging

Post by Pixi6s » Thu Jul 07, 2011 1:12 pm

You mean the abort key? I commented out

Code: Select all

Keyboard.AbortKey = System.Windows.Forms.Keys.Pause;
only. That was the first thing I did and it did not fix my problem. Was there more to comment out than that one line?

Thanks
Sierra

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: 3.0.2 slow when debugging

Post by Support Team » Thu Jul 07, 2011 1:45 pm

Support Team wrote:The "LowLevelHooksTimeout" registry key is set (done by the Microsoft Visual Studio 2010 setup)
Support Team wrote:For removing the "LowLevelHooksTimeout" key, please search your registry for a key with name "LowLevelHooksTimeout" and delete it.
No I mean the registry key "LowLevelHooksTimeout" set by Visual Studio. Please delete this key from your registry and try it again.

Regards,
Peter
Ranorex Team
.
Image

Pixi6s
Posts: 92
Joined: Tue Jun 28, 2011 8:57 pm

Re: 3.0.2 slow when debugging

Post by Pixi6s » Fri Jul 08, 2011 1:17 pm

The first time through I only found ModifiedLowLevelHooksTimeout, which I did rename. This time through I did find it but not where I would have expected it (I must have missed starting my search from the top level initially).

I renamed everything I found with LowLevelHooksTimeout in it and turned the progress dialog back on and it has returned. I haven't rebooted yet but it doesn't look promising.