3.0.4 slow when opening files and editing user code

Bug reports.
User avatar
Gunner1980
Posts: 89
Joined: Mon Apr 05, 2010 8:44 pm
Location: Austin, Texas

3.0.4 slow when opening files and editing user code

Post by Gunner1980 » Tue Jul 12, 2011 7:28 pm

Just downloaded 3.0.4 and am going back to 3.0.2. 3.0.4 is super slow when opening recordings/updating user code. If I open a recording I can't click on anything for a good 5 seconds. If I want to change user code there is significant intellisense lag. Additionally when I open a user code file I can't scroll or highlight anything for a few seconds. Every time I try to make a change in the user code something is lagging, it's like I am typing and seeing the letters i am typing several seconds later.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: 3.0.4 slow when opening files and editing user code

Post by Support Team » Wed Jul 13, 2011 9:32 am

Hi,

thanks for reporting the bug.
This is a known issue with large test suite projects and will be fixed within our next release which will be available at the first August week at the latest.
So please be patient and work with Ranorex 3.0.2 until our next release will be available.

Kind regards,
Tobias
Support Team
.
Image

User avatar
sdaly
Posts: 238
Joined: Mon May 10, 2010 11:04 am
Location: Dundee, Scotland

Re: 3.0.4 slow when opening files and editing user code

Post by sdaly » Wed Jul 13, 2011 12:00 pm

Are there any release notes for 3.0.4?

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: 3.0.4 slow when opening files and editing user code

Post by Support Team » Wed Jul 13, 2011 12:02 pm

Hi Scott,

release notes can be found at:
http://www.ranorex.com/download/release-notes.html

Kind regards,
Tobias
Support Team
.
Image

User avatar
Gunner1980
Posts: 89
Joined: Mon Apr 05, 2010 8:44 pm
Location: Austin, Texas

Re: 3.0.4 slow when opening files and editing user code

Post by Gunner1980 » Wed Jul 13, 2011 5:28 pm

Support Team wrote:Hi,

thanks for reporting the bug.
This is a known issue and will be fixed within our next release which will be available at the first August week at the latest.
So please be patient and work with Ranorex 3.0.2 until our next release will be available.

Kind regards,
Tobias
Support Team
Roger that thanks!