6.1.0 Chrome

Bug reports.
rsa
Posts: 3
Joined: Thu Nov 17, 2016 1:41 pm

6.1.0 Chrome

Post by rsa » Thu Nov 17, 2016 2:43 pm

I am using Ranorex 6.1.0 on a Windows 7 machine with Chrome 54 and sometimes Ranorex does not recognize any elements inside a page opened with Chrome. Using spy to try to track and identify any element inside only recognizes a part of the Chrome window but nothing more inside. I have attached an image of the output given by Spy in such a case.

This problem often persists closing and restarting both Chrome and Ranorex and sometimes even restarting the PC. I am yet to discover any pattern about when and for how long this issue is encountered.
Attachments
RanorexUnknownChromeSpy.png
RanorexUnknownChromeSpy.png (30.2 KiB) Viewed 573 times

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: 6.1.0 Chrome

Post by krstcs » Thu Nov 17, 2016 8:05 pm

When did the issue start? What changes occurred just before this issue presented itself?

I don't have any issues with Chrome 54/Ranorex 6.1.1, so I don't think it is a bug in the newest version.

First, update to Ranorex 6.1.1 and check if the issue continues. 6.1.0 is no longer being updated and bug fixes will only be applied to the current version, so any issues you report on 6.1.0 might have already been addressed in 6.1.1 and may not be relevant any longer.

Second, make sure that you have the Ranorex Chrome extension installed and enabled. You should get a technology limitation warning if you don't, but maybe you didn't see it.
Shortcuts usually aren't...

hbattjes
Posts: 2
Joined: Wed Nov 09, 2016 12:53 pm

Re: 6.1.0 Chrome

Post by hbattjes » Thu Nov 24, 2016 9:41 am

We are running Ranorex on a VM and sometimes get the following error while closing Chrome:

Action 'close' failed on element '{WebDocument:Chrome}'.
Failed to read from an IPC Port: The pipe has been ended.

This seems to have started after the update to 6.1.x
@krstcs I saw you had the same problem a time ago. (topic: bug intermittent exceptions on close of chrome) Did you find a solution/work around?

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: 6.1.0 Chrome

Post by krstcs » Mon Nov 28, 2016 3:10 pm

First, I have not found a solution, but I haven't seen it in a while either.

Second, please do not hijack (change topics) of threads. This can cause confusion. If you have a related topic, please post a new thread with a link to the original, or post in an existing topic that discusses the same issue.

Thanks!
Shortcuts usually aren't...