A website using frame and webspy found webellement not worki

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
ccaipei
Posts: 2
Joined: Tue Mar 17, 2009 7:02 pm

A website using frame and webspy found webellement not worki

Post by ccaipei » Tue Mar 17, 2009 7:21 pm

I have a FortigateB30 and want to do automation QA using C#.net.
I wrote a c# window application and access the webpage through http:\\192.168.1.99 and try to click the webelement which was found by webspy. The program can't find and show null. the path looks like /frame[2]/body/.... And I checked the webpage direct to 192.168.1.99/index and the html for index is simple with several lines for frame and nothing for body...
How can i go through this bottleneck?
Help and Thanks.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Post by Support Team » Wed Mar 18, 2009 11:13 am

What version of Ranorex and what browser are you using ?
Do the frames contain cross-site/domain content ?

Michael
Ranorex Team

ccaipei
Posts: 2
Joined: Tue Mar 17, 2009 7:02 pm

Post by ccaipei » Wed Mar 18, 2009 1:13 pm

The version of Ranorex is 1.5.1.
It looks like inside the frame is normal page.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Post by Support Team » Wed Mar 18, 2009 1:27 pm

Please try to get the appropriate frame from the Frames property and
try using this as a basis for your automation code.
e.g.

Code: Select all

WebDocument frameSet = ....
WebDocument frameDocument = frameSet.Frames[0];

frameDocument.Find(...)

If you are new to Ranorex please consider using version V2.0.1

Michael
Ranorex Team

Anu
Posts: 13
Joined: Tue May 10, 2011 5:10 pm

Re: A website using frame and webspy found webellement not worki

Post by Anu » Fri May 13, 2011 8:19 pm

Michael,

Can you elaborate this further? I have a similar situation of my webapp being frames inside frames. A typical object in a spy is like this..
/dom[@domain='mydomain']/frameset/frameset[@id='framename']/frameset[2]/frame[@name=framename2]/body/div/div[6]/tablr/tbody/tr[3]/td[@id='la_01']

If I have to find the content of the table and display in my result, how do i go about it??

thanks
Anu

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: A website using frame and webspy found webellement not worki

Post by Support Team » Mon May 16, 2011 8:57 am

Hi,

I answered your question on following post
http://www.ranorex.com/forum/find-numbe ... html#p8772

It looks like the same issue and you have double-posted it.

Regards,
Peter
Ranorex Team
.
Image