After upgrade 9.2.0 > 9.3.3 TestSuite Won't Run

Bug reports.
Hondo
Posts: 47
Joined: Thu Nov 03, 2016 12:03 am

After upgrade 9.2.0 > 9.3.3 TestSuite Won't Run

Post by Hondo » Sat Sep 26, 2020 1:43 am

Ran 'prerequisites.exe' and then the 9.3.3 installer. => no errors. both installs appeared to work fine.

Loaded up one of my regression solutions and tried to run the TestSuite.
Strange message:
"C:\Program Files (x86)\Ranorex\Studio\Bin\AddIns\Misc\PackageManagement\NuGet.exe" restore "AcquisitionPanelStress.sln"
MSBuild auto-detection: using msbuild version '15.9.21.664' from 'C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\MSBuild\15.0\bin'.
Nothing to do. None of the projects in this solution specify any packages for NuGet to restore.


Searched the Forum and saw instructions to re-install .Net 4.6.2 => no diff
Did it a couple more times with some reboots in between.. still no diff.
Uninstalled everything and then re-installed.. still no diff.

Rolled back to v9.2.0 and ran a different regression solution and it worked.
The first regression solution I loaded appears to be jacked now and needs to be restored to v9.2.0

What do I have to do to get v9.3.3. to work?

Help.

Thanks.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6233
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: After upgrade 9.2.0 > 9.3.3 TestSuite Won't Run

Post by odklizec » Sat Sep 26, 2020 12:24 pm

Hi,

Have you tried to install .Net 4.6.2 SDK package?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

Hondo
Posts: 47
Joined: Thu Nov 03, 2016 12:03 am

Re: After upgrade 9.2.0 > 9.3.3 TestSuite Won't Run

Post by Hondo » Mon Sep 28, 2020 5:34 pm

Yes. Multiple times. Pain in the neck.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6233
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: After upgrade 9.2.0 > 9.3.3 TestSuite Won't Run

Post by odklizec » Mon Sep 28, 2020 9:10 pm

Hi,

Just in case, are you sure you installed 4.6.2 SDK and not just 4.6.2 runtimes? SDK is a different package!
https://www.microsoft.com/en-us/downloa ... x?id=53321
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

Hondo
Posts: 47
Joined: Thu Nov 03, 2016 12:03 am

Re: After upgrade 9.2.0 > 9.3.3 TestSuite Won't Run

Post by Hondo » Mon Sep 28, 2020 9:53 pm

Please enough of the back and forth about .NET 4.6.2 SDK.

I already said that I had installed and re-installed it multiple times.
Searched the Forum and saw instructions to re-install .Net 4.6.2 => no diff
Did it a couple more times with some reboots in between.. still no diff.
Uninstalled everything and then re-installed.. still no diff.


Yes I used that link for the .NET 4.6.2 SDK gleaned from a post I found when I searched the Forum.

Never mind. We'll just stick with v9.2.0 (which is working) and maybe move to another product.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6233
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: After upgrade 9.2.0 > 9.3.3 TestSuite Won't Run

Post by odklizec » Tue Sep 29, 2020 7:26 am

Hi,

The reason why I've repeatedly suggested .Net SDK is, that from your answer was not entirely clear if you've reinstalled .Net or .Net SDK package.

Anyway, after googling out your particular issue, it seems that it's somehow Visual Studio/Nuget related issue and not exactly Ranorex related problem. Check this post with possible workaround:
https://github.com/NuGet/Home/issues/7827
particularly this answer:
https://github.com/NuGet/Home/issues/78 ... -514084289
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration