Agent reports wrong version number

Ask general questions here.
bwood
Posts: 16
Joined: Mon Jan 28, 2019 2:52 pm

Agent reports wrong version number

Post by bwood » Tue Aug 27, 2019 1:36 pm

I am trying to install and run Ranorex agent on another machine in my network. I installed version 6.0.0 from the link in Studio. However, once the agent is setup I get an error stating that I must install a newer version (at least 5.0.0). I'm not sure what to do as I thought 6.0.0 was greater than 5.0.0 :D

The exact error I am getting is

Code: Select all

Newer version required. Please update to Agent 5.0.0 or later.   at Ranorex.Dex.Client.Panel.Logic.ViewModels.AgentContainerViewModel.<CreateAgentAsync>d__44.MoveNext()
Attachments
version2.PNG
version2.PNG (5.19 KiB) Viewed 79 times
version.PNG
version.PNG (4.07 KiB) Viewed 79 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11963
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Agent reports wrong version number

Post by Support Team » Tue Aug 27, 2019 8:49 pm

Hi bwood,

I suspect you are using an older version of Ranorex which is expecting Agent 5.0.0, however you have 6.0.0 installed. The Ranorex Remote Agent is not forward or backward compatible and must be used with the version of Ranorex is was released with. If you are using an older version of Ranorex (< 9.1), you have two options, (1) upgrade Ranorex to 9.1 (compatible with Agent 6.0.0), or (2) downgrade agent to the version compatible with your current version of Ranorex. I have private messaged you our download archive link which can provide the version of agent compatible for your version of Ranorex (we prefer this link not to be public).

1.png
1.png (32.37 KiB) Viewed 61 times

I hope this makes sense and resolves your issue!

Regards,
Ned
.
Image

bwood
Posts: 16
Joined: Mon Jan 28, 2019 2:52 pm

Re: Agent reports wrong version number

Post by bwood » Tue Aug 27, 2019 9:51 pm

Thank you, that fixed it.