All variables become unbound after upgrade

Bug reports.
costamesakid
Posts: 94
Joined: Tue Jun 16, 2009 10:27 pm

All variables become unbound after upgrade

Post by costamesakid » Tue Oct 15, 2013 8:05 pm

All my variables became unbound after upgrading from 4.0.2 to 4.1.1. We have reproduced this on multiple systems. A situation like this would take weeks to fix. Please fix this issue ASAP. Thanks
ScreenHunter_432 Oct. 15 11.00.jpg
ScreenHunter_432 Oct. 15 11.00.jpg (384.71 KiB) Viewed 1022 times
Last edited by Support Team on Wed Oct 16, 2013 8:12 am, edited 1 time in total.
Reason: Shouting in topic

User avatar
Support Team
Site Admin
Site Admin
Posts: 11710
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: All variables become unbound after upgrade

Post by Support Team » Thu Oct 17, 2013 9:22 am

Hello,

Unfortunately, we couldn't reproduce your issue.
Would it be possible to send us your test project or a sample project?
Please describe all steps that you did to reproduce your issue.

Thank you in advance.

Regards,
Markus (T)
.
Image

lyn5000
Posts: 50
Joined: Mon Feb 13, 2012 5:52 pm

Re: All variables become unbound after upgrade

Post by lyn5000 » Tue Oct 22, 2013 10:34 pm

We also see the issue with Ranorex 4.1.0.

It happens randomly for us during development and updating from SVN source control. Haven't narrowed it down further yet.

We'll have been editing the test suite on a client machine or do a new update from SVN source control through Ranorex Studio and then notice the .rxtst gets modified on the client with all the variables in the test suite suddenly unbound. We have to revert the .rxtst to the SVN version again to fix the file each time.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11710
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: All variables become unbound after upgrade

Post by Support Team » Wed Oct 23, 2013 12:29 pm

Hello lyn5000,

Unfortunately, we would need more information about your issue.

Is it possible to find out who or what caused a change in the *.rxtst file?
Do you use the same Ranorex version among your team?
Could it be that someone changed the data source or the data connector?

Thanks in advance.

Regards,
Markus (T)
.
Image