Alt-Tab is disabled when Studio starts

Ranorex Spy, Recorder, and Studio.
jackson.delahunt
Posts: 19
Joined: Wed Sep 18, 2013 9:01 am

Alt-Tab is disabled when Studio starts

Post by jackson.delahunt » Thu Sep 19, 2013 9:04 am

Hi,

I use the alt-tab key sequence constantly, but when Ranorex Studio starts, Alt-Tab is disabled system wide. Is there a way of fixing this? It makes my computer excruciating to use! When I exit Studio, the functionality is restored.

Thanks,


Jackson

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Alt-Tab is disabled when Studio starts

Post by Support Team » Thu Sep 19, 2013 4:22 pm

Hello,

Unfortunately, I couldn't reproduce your issue.

Which Ranorex version do you use?
Do you use <ALT>+<Tab> during a test execution?

Regards,
Markus (T)
.
Image

mrollins
Posts: 10
Joined: Wed Aug 28, 2013 6:35 pm

Re: Alt-Tab is disabled when Studio starts

Post by mrollins » Thu Sep 19, 2013 9:14 pm

I also see this issue on Windows 8 using Ranorex 4.1.0. I've had it ever since I started testing on Windows 8 with 4.0.2.

I do not use Alt or Tab in any of my scripts.

The only thing unusual about my configuration is that I have disabled UAC in the registry (which prevents Win8 Metro from starting). Though enabling it again didn't seem to help.

--
Michael

jackson.delahunt
Posts: 19
Joined: Wed Sep 18, 2013 9:01 am

Re: Alt-Tab is disabled when Studio starts

Post by jackson.delahunt » Fri Sep 20, 2013 12:15 am

Support Team wrote:Hello,

Unfortunately, I couldn't reproduce your issue.

Which Ranorex version do you use?
Do you use <ALT>+<Tab> during a test execution?

Regards,
Markus (T)
Hi Markus,

I'm using Ranorex Studio 4.1.0.25227 on Windows 8 build 6.2.9200. Alt+Tab is not used in recording, just in every day use, for example, switching between a web browser and studio. When you're used to the instant switch available through Alt+Tab, the time taken to move the mouse down to the task bar, wait for it to appear, click the program you want, and move your mouse back up, it gets very frustrating, especially when you have to repeat it 50 times a day or more. Frustration aside, Windows core functionality shouldn't be changed by using a third party application. Maybe it's a Windows 8 specific issue? Hopefully we can get it resolved! :)

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Alt-Tab is disabled when Studio starts

Post by Support Team » Fri Sep 20, 2013 1:55 pm

Hello,

Thank you for the description.
Unfortunately I cannot reproduce the issue. I have tested the behavior on a Windows 8 build 6.2.9200 as well and had no issue using Alt+Tab in order to bring another application in the foreground. It must be a specific setting on your machine.
It is hard to provide a solution when I cannot reproduce the issue.
You could try to reinstall Ranorex completely. Maybe this will solve the issue.

Regards,
Bernhard
.
Image

jackson.delahunt
Posts: 19
Joined: Wed Sep 18, 2013 9:01 am

Re: Alt-Tab is disabled when Studio starts

Post by jackson.delahunt » Mon Sep 30, 2013 4:00 am

Hi Bernhard,

That's frustrating to hear. I am using the trial version currently in evaluation mode. Could this have something to do with it? I have reinstalled Ranorex, but this hasn't fixed the issue. I also note that the Win+X key combination stops functioning whilst Ranorex is running, but other Win key functions (such as Win+D and Win+B) still continue to work. Once again, when I exit Ranorex, Win+X works again.

Are there any other diagnostic steps I can take to help troubleshoot this?

jackson.delahunt
Posts: 19
Joined: Wed Sep 18, 2013 9:01 am

Re: Alt-Tab is disabled when Studio starts

Post by jackson.delahunt » Wed Oct 02, 2013 2:03 am

Furthermore, others in my workplace are reporting this issue, so I am not alone in experiencing the error.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Alt-Tab is disabled when Studio starts

Post by Support Team » Wed Oct 02, 2013 5:20 pm

Hello,

We tried to reproduce the issue on some machines, but unfortunately I cannot reproduce the issue.
Is your machine a virtual machine or is this a physical machine?

Regards,
Bernhard
.
Image

jackson.delahunt
Posts: 19
Joined: Wed Sep 18, 2013 9:01 am

Re: Alt-Tab is disabled when Studio starts

Post by jackson.delahunt » Thu Oct 03, 2013 12:17 am

Hi Bernhard,

Thanks for your response. It is a physical machine.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Alt-Tab is disabled when Studio starts

Post by Support Team » Fri Oct 04, 2013 6:32 pm

Hello,

That's weird. Every key combination works on our machines even if Ranorex is installed. Could you please try to uninstall Ranorex completely from your machine and check if the key combinations are working?
Maybe the reason is another program.

Regards,
Bernhard
.
Image

swmatisa
Posts: 122
Joined: Fri Aug 05, 2011 7:52 am

Re: Alt-Tab is disabled when Studio starts

Post by swmatisa » Mon Oct 07, 2013 8:22 am

Hello,

2 years ago, I had a quite same problem:http://www.ranorex.com/forum/google-des ... t2522.html

Hope this help
SW

jackson.delahunt
Posts: 19
Joined: Wed Sep 18, 2013 9:01 am

Re: How to automate testing of two interacting applications

Post by jackson.delahunt » Mon Oct 07, 2013 11:46 pm

swmatisa wrote:Hello,

To do quite the same and simple 8) :
I run my client application on the same computer as the server application or I use a ftp client to check that the file has been correctly received.

Hope this help
Thank you! That fixed my problem. It was so frustrating! I had to disable "Use asynchronous dispatching of mouse and keyboard events", then Alt-Tab would work again.

Could the support team explain what "Use asynchronous dispatching of mouse and keyboard events" actually does please?

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Alt-Tab is disabled when Studio starts

Post by Support Team » Tue Oct 08, 2013 4:30 pm

jackson.delahunt wrote:Could the support team explain what "Use asynchronous dispatching of mouse and keyboard events" actually does please?
That setting influences the way Ranorex records keyboard and mouse actions. If this setting is enabled, Ranorex swallows all events from the physical keyboard/mouse and then - after recording those events - generates the events again to be dispatched by the system.

This is needed to allow for unlimited processing time when recording the events and generating information about the associated UI elements, like RanoreXPath generation and so on, before the keyboard/mouse event is actually dispatched to the system and can influence the application under test.

A problem when this setting is enabled, can be that some (security) applications do not allow "replayed" keyboard/mouse events and filter some of the events or react themselves on those events and remove them from the system. Do you have a security/anti-virus app installed on your machine?

Regards,
Alex
Ranorex Team
.
Image

jackson.delahunt
Posts: 19
Joined: Wed Sep 18, 2013 9:01 am

Re: Alt-Tab is disabled when Studio starts

Post by jackson.delahunt » Tue Oct 08, 2013 11:04 pm

Hi Alex,

Thank you for clarifying that. Very interesting! Yes, we use McAfee antivirus. This may be causing the issue. Unfortunately I cannot disable it to confirm this hypothesis.

Thank you to you and swmatisa for your assistance in the matter!