Android failed to start app because event was not received

Mobile Testing, Android App Testing.
Sai
Posts: 22
Joined: Tue Jul 18, 2017 10:59 am

Android failed to start app because event was not received

Post by Sai » Fri Sep 08, 2017 7:39 am

Hello Users,

I am having 1 year experience on Ranorex Android Mobile automation. few days ago we have got a requirement on Cool Pad 3600I Android device.

I am able to record user actions against many Android mobile applications on Cool Pad 3600I successfully but i am getting the below error when i start execution (at least Ranorex is not able open APK files) and i am able work Cool Pad 3600I by other automation tool.

"failed to start app 'Contactspk.apk' because event was not received within the specified timeout of '00:01:00 Minute"

i have increased the Connect timeout in the Global Settings (Plugins -- > Mobile )but getting the same error.

Please check system requirements below

Rx Version: 7.1.0
Device Name: Cool Pad 3600I
Android Version: 6
Type of Connection: USB (Hope this is not the reason for this issue because i am able automate other Android devices)

If anyone has some suggestions, I would appreciate direction or offer a better solution.

Thanks,
Sai

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3937
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Android failed to start app because event was not received

Post by odklizec » Fri Sep 08, 2017 7:47 am

Hi,

I would definitely suggest to try Wifi type of connection. Also, have you checked android USB troubleshoting guide:
https://www.ranorex.com/help/latest/and ... cteddevice
Don't forget there must be installed correct USB driver on PC with Ranorex!
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

Sai
Posts: 22
Joined: Tue Jul 18, 2017 10:59 am

Re: Android failed to start app because event was not received

Post by Sai » Fri Sep 08, 2017 10:46 am

Thank you for your reply.

I have installed correct USB driver on my PC.

This is the issue when i start execution (No application lunching issue when i start recording) . Please check my error screenshot (mobile connection issue.png).

i think this is not a connection problem because still mobile device is connected to Ranorex (i can see connection status on Endpoints) when i start recording and execution.

I am able able to see my device with help of ADB drive on command prompt at time of execution. find the attached (ADB driver.png).

When i install any software first time in my mobile, it will ask me provide some permissions(attached Any sw.png). Any thing needs to change mobile settings as per this screenshot(attached Any sw.png)?

Sai
Attachments
Any sw.JPG
Any sw.JPG (30 KiB) Viewed 671 times
ADB driver.JPG
ADB driver.JPG (15.57 KiB) Viewed 671 times
mobile connection issue.JPG
mobile connection issue.JPG (21.25 KiB) Viewed 671 times