Android Instrumentation Failed

Mobile Testing, Android App Testing.
VaunMakuza
Posts: 2
Joined: Fri Feb 21, 2014 8:34 pm

Android Instrumentation Failed

Post by VaunMakuza » Fri Feb 21, 2014 8:37 pm

Hello!

I'm a new user of Ranorex (in fact using the trial to see if we want to use this program or not!) and I can't seem to deploy my APK to my android. I'm following the android user guide.

I used the test one they recommend to deploy and that works fine, but when I try one of my own APK's I get the following:

Instrumentation failed...

Please make sure that
- The APL is not obfuscated.
- You are using API level 8 or above.
- No uninstrumented APK version is installed on the device.

And the error details are:

System.TimeoutException: Deploying the application failed because it could not be deployed within the configured timeout of '00:01:00'.
at Ranorex.Plugin.Mobile.DeploymentService.WifiDeploymentService.SendData(IPAddress addr, Int32 port, String path, String packageName)
at Ranorex.Plugin.Mobile.DeploymentService.WifiDeploymentService.DoDeployment()


Any help would be great!

Thanks,

Tyler

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Android Instrumentation Failed

Post by Support Team » Tue Feb 25, 2014 5:52 pm

Hello Tyler,

Another user had a similar issue which was discussed in the topic "Instrumented Android APK failed (Error occurred)" which can be found using the following URL: http://www.ranorex.com/forum/instrument ... t4092.html
Please let me know if this doesn't solve your problem.

Regards,
Bernhard
.
Image

VaunMakuza
Posts: 2
Joined: Fri Feb 21, 2014 8:34 pm

Re: Android Instrumentation Failed

Post by VaunMakuza » Wed Feb 26, 2014 4:40 pm

Hey Bernhard,

Thanks for the reply!

I looked over the page you linked, and our API is over level 8, (level 10 actually), and is not obfuscated. And it looks like Ranorex is above version 4, so the special characters shouldn't be an issue anymore! So not really sure whats causing it not to work!

Thanks!

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Android Instrumentation Failed

Post by Support Team » Fri Feb 28, 2014 4:15 pm

Hi VaunMakuza,

You can also try to instrument the *.apk file with Source Code as described in the section "Instrumentation with Source Code" in our user guide.
If this is not possible it would be a big help to get you *.apk file in order to analyze the issue in more detail.
If you do not want to post your *.apk file in the forum you can also send it to [email protected].

Regards,
Bernhard
.
Image

samira
Posts: 1
Joined: Mon Jan 04, 2016 8:50 am

Re: Android Instrumentation Failed

Post by samira » Mon Jan 04, 2016 8:55 am

hi
i have the same problem as mentioned here.
i use Ranorex 5.4.4 and service 1.8.3 and jre 7. I also run these programs on a win 7 on a virtual machine.
but when i want to ad an app i face with this error.
would u help me? it is very important for me.
thanks.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Android Instrumentation Failed

Post by Support Team » Tue Jan 05, 2016 2:03 pm

Hi samira,

May I ask you if you have already tried increasing the "Deploy time out" in the Global Settings -> Plugins Tab?
Settings_Plugin_Mobile.png
Settings_Plugin_Mobile.png (24.56 KiB) Viewed 1173 times
Sometimes it can happen that the deployment of bigger application needs more than one minute. Therefore, please try increasing this value to two or more.

Please let me know if the problem still occurs afterwards.

Regards,
Markus (S)
.
Image