Android studio build

Mobile Testing, Android App Testing.
Klinke
Posts: 4
Joined: Wed Nov 12, 2014 5:09 pm

Android studio build

Post by Klinke » Fri Jun 05, 2015 12:45 pm

Hello,

We're using Ranorex for testing our Android application for a few months now. Everything was fine when the developers built .apks with Eclipse IDE.

Now they have moved to Android studio and Ranorex can't load the application (even though the apk can be installed manually on the device/emulator).

Via Splunk (service for logging crashes on Android app) we can see a crash log in the moment of deploying app via Ranorex on mobile device. Crash log says:

Code: Select all

java.lang.NullPointerException: Attempt to invoke virtual method 'void java.io.FileDescriptor.setInt$(int)' on a null object reference
 at java.net.PlainSocketImpl.accept(PlainSocketImpl.java:93)
 at java.net.ServerSocket.implAccept(ServerSocket.java:216)
 at java.net.ServerSocket.accept(ServerSocket.java:140)
 at com.ranorex.communication.ListenThread.run(ListenThread.java:55)
 at java.lang.Thread.run(Thread.java:818)
Also we have a problem with ResourceIDs and RIds. They are visible in Ranorex for mobile app built using Eclipse and they aren't visible for app built using Android studio.

Thanks in advance,
Krešo

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Android studio build

Post by Support Team » Thu Jun 11, 2015 12:55 pm

Hi all,


Just to keep you up-to-date, we are currently in contact with Krešo by email. We will provide our solution in this forum as soon as we have found the problem.

Thank you for your patience.

Regards,
Markus (S)
.
Image

liutingdu
Posts: 2
Joined: Thu Jul 16, 2015 11:54 am

Re: Android studio build

Post by liutingdu » Thu Jul 16, 2015 12:06 pm

Hi,

I am getting the same exception for my Android project, it only happens after I upgraded from BugSense to SplunkMint, I see you mentioned you are using Splunk as well, so maybe they are the same error..

Please let me know if you find a solution..

Many thanks,
Liuting

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Android studio build

Post by Support Team » Fri Jul 17, 2015 1:31 pm

Hi all,

It seems that the issue is somehow releated to SplunkMint as stated in the following forum posting

http://www.ranorex.com/forum/applicatio ... tml#p33264

May I ask you if you can try to run your application without using Splunk Mint?
Please let me know if the problem still occurs when doing so.

Thank you.

Regards,
Markus (S)
.
Image

liutingdu
Posts: 2
Joined: Thu Jul 16, 2015 11:54 am

Re: Android studio build

Post by liutingdu » Thu Jul 23, 2015 10:21 am

Hi,

It turns out is caused by a known issue with SplunkMint: "There are known compatibility issues with network monitoring and server-side sockets. If you use server-side sockets, you should diable network monitoring entirely. "

Disable network monitoring works for me.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Android studio build

Post by Support Team » Mon Jul 27, 2015 12:07 pm

Hi liutingdu,

Thank you for your update and for providing your solution.
I'm glad that you were able to overcome this issue.

Regards,

Markus (S)
.
Image

Klinke
Posts: 4
Joined: Wed Nov 12, 2014 5:09 pm

Re: Android studio build

Post by Klinke » Mon Feb 22, 2016 4:40 pm

Hello,

I am having problem with instrumenting Repsly apk.

last time we had a problem with instrumentation, Splunk bug tracker was making problem and we have resolved this by building app without this solution inside. However, the apk I am trying to instrument now does not have Splunk inside but I am still having this issue.

Could you please help me out?

Thanks much!
Kreso

P.S.
The issue log I am receiving is following:

System.Exception: Failed to decompile the APK file. See details for more information: Exception in thread "main" brut.androlib.err.UndefinedResObject: resource spec: 0x01010490
at brut.androlib.res.data.ResPackage.getResSpec(ResPackage.java:59)
at brut.androlib.res.data.ResTable.getResSpec(ResTable.java:65)
at brut.androlib.res.data.ResTable.getResSpec(ResTable.java:61)
at brut.androlib.res.data.value.ResReferenceValue.getReferent(ResReferenceValue.java:57)
at brut.androlib.res.data.value.ResStyleValue.serializeToResValuesXml(ResStyleValue.java:54)
at brut.androlib.res.AndrolibResources.generateValuesFile(AndrolibResources.java:502)
at brut.androlib.res.AndrolibResources.decode(AndrolibResources.java:252)
at brut.androlib.Androlib.decodeResourcesFull(Androlib.java:135)
at brut.androlib.ApkDecoder.decode(ApkDecoder.java:102)
at brut.apktool.Main.cmdDecode(Main.java:165)
at brut.apktool.Main.main(Main.java:81)

at Ranorex.Plugin.Mobile.Tools.Android.Instrumentation.ApkFileInstrumenter.DecompileApkFile(String apkFilePath, Boolean showProcessWindows, IPathService pathService, InstrumentApkOptions deployOptions)
at Ranorex.Plugin.Mobile.Tools.Android.Instrumentation.ApkFileInstrumenter.Instrument(String apkFilePath, Int32 port, InstrumentApkOptions deployOptions, BackgroundWorker bgw)
at Ranorex.Controls.Instrumentation.Workers.AndroidWorker.Run()
at Ranorex.Controls.AndroidInstrumentProgressPage.bgw_DoWork(Object sender, DoWorkEventArgs e)

Klinke
Posts: 4
Joined: Wed Nov 12, 2014 5:09 pm

Re: Android studio build

Post by Klinke » Fri Feb 26, 2016 9:35 am

Extending the timeout of instrumentation and deploy to 5 and 3 minutes + suggestion from Ranorex worked for me!

Thanks!
Please delete the 1.apk file from the following directory
%userprofile%/apktool/framework

Please verify that the latest APKtool version is installed on your system by entering the following command in your cmd window
C:\Program Files (x86)\Ranorex 5.4\bin\Rxenv\android\tools\apkTool\apktool.bat