Application Not Loading in recording section

Mobile Testing, Android App Testing.
amitgupta
Posts: 8
Joined: Sun Mar 28, 2021 7:58 pm

Application Not Loading in recording section

Post by amitgupta » Fri Apr 30, 2021 9:14 am

Dear Team,

After doing instructional wizard application under tools , I am getting application in my android mobile phone but not displaying application in loading section after clicking 'Record' button .I can see that my mobile is successfully connected with ranorex and can see icon in ranorex.

Without recording , When I add action for run application , then I was able to execute the script for launching meridian app but i was not able to record script for mobile android application because application didn't load in recording section.

Could you please have a look on below screen shot for better understanding and help me for the same?

Thanks and Regard
Amit Gupta
Attachments
Screenshot_2021-04-30-13-03-14-297_ranorex.android.services.jpg
Screenshot_2021-04-30-13-03-14-297_ranorex.android.services.jpg (117.15 KiB) Viewed 54 times
ranorex eroror.jpg
ranorex eroror.jpg (212.89 KiB) Viewed 54 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6544
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Application Not Loading in recording section

Post by odklizec » Fri Apr 30, 2021 9:55 am

Hi,

As far as I remember, "recording" mobile apps has been removed in Ranorex 8.0? You need to track and add the xpaths and actions manually. But take me with caution. I'm not automating mobile apps ;) I just remember it was removed and 8.0 release notes says so (Recording on mobile devices discontinued).
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

amitgupta
Posts: 8
Joined: Sun Mar 28, 2021 7:58 pm

Re: Application Not Loading in recording section

Post by amitgupta » Thu May 06, 2021 8:37 pm

Team ,Could you share me some tips or document how can we find XPath as easiest way for mobile application and also share any free tool with document if we can see all mobile operation on PC( i tried with mymobiler tool by usb cable but no luck )

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6544
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Application Not Loading in recording section

Post by odklizec » Fri May 07, 2021 10:03 am

Hi,

The only way how to find xptahs on mobile devices is Ranorex Spy. Please follow the steps described in the User Guide:
https://www.ranorex.com/help/latest/web ... ildthetest
Basically, if you click a mobile element in Ranorex Spy preview window, there should be displayed xpath for given element and element tree should be expanded and scrolled into view. If there is no correct element found (e.g. due to an overlay window over UI), you will have to find the element in question by expanding and scrolling the element tree in Spy and finding the element manually.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration