Automation freezing on Windows 10.0.17134 Build 17134

Ask general questions here.
tvu
Posts: 195
Joined: Tue Apr 07, 2015 10:47 pm

Automation freezing on Windows 10.0.17134 Build 17134

Post by tvu » Tue May 22, 2018 12:13 am

I have a Jenkins setup to run my automation. The jobs are run via a Windows Batch Command step. My RunTimePCs are Windows 10 machines. I did a Windows update to the latest security build last week to Version 10.0.17134 Build 17134. The automation now freezes during the run. Sometimes it takes 30 minutes. Sometimes it takes 2 hours before it happens. On the Jenkins console output, it would show that it's just frozen at a random command. No error is given. It just won't progress. The Jenkins job will continue once I remote desktop onto the machine. I don't do anything except remote into the machine. The job would then proceed. But, at the point, it would just fail because it would have been frozen for minutes or hours.

Anyone else having this issue?

We are using
Ranorex v8.0.1
Windows 10.0.17134 Build 17134
Java SE build 1.8.0_171-b11

ahoisl
Certified Professional
Certified Professional
Posts: 125
Joined: Fri Sep 07, 2007 8:16 am

Re: Automation freezing on Windows 10.0.17134 Build 17134

Post by ahoisl » Tue May 22, 2018 10:36 pm

Hmm, this could be related to a bug in Win 10 April Update that we reported and that could cause UI automation to hang:
https://social.technet.microsoft.com/Fo ... derPreview

First, please upgrade to the latest Ranorex release v8.1.1, which already addresses an issue in the latest Windows 10 update.

If upgrading does not help, you can try to change a Ranorex plugin setting, namely the "UIA -> Enable debugging mode for Windows apps" setting to "false". This may cause Windows apps to be activated, but should be a workaround for the above bug.

Regards,
Alex
Ranorex Team

tvu
Posts: 195
Joined: Tue Apr 07, 2015 10:47 pm

Re: Automation freezing on Windows 10.0.17134 Build 17134

Post by tvu » Tue May 22, 2018 10:45 pm

Thanks Alex!

I will try to upgrade to v8.1.1 and see if it fixes the issues. Sounds like the issue is related to desktop UI automation. We are automating mobile apps, but hopefully this will fix the issue.

sellebrd
Posts: 1
Joined: Thu Aug 09, 2018 9:58 pm

Re: Automation freezing on Windows 10.0.17134 Build 17134

Post by sellebrd » Thu Aug 09, 2018 10:16 pm

I have this exact same problem (Ranorex v8.0.1, Windows 10.0.17134 Build 17134, Java SE build 1.8.0_171-b11)!

I have not upgraded to Ranorex v8.2 yet. First, I want to be able to execute all my tests on Ranorex v8.0.1 and keep baseline results, so that I can compare it to results for when we upgrade to Ranorex v8.2.

So will or did setting "UIA -> Enable debugging mode for Windows apps" to "false" fix the issue?

ahoisl
Certified Professional
Certified Professional
Posts: 125
Joined: Fri Sep 07, 2007 8:16 am

Re: Automation freezing on Windows 10.0.17134 Build 17134

Post by ahoisl » Sat Aug 11, 2018 8:11 pm

sellebrd wrote:
Thu Aug 09, 2018 10:16 pm
So will or did setting "UIA -> Enable debugging mode for Windows apps" to "false" fix the issue?
Maybe, since I cannot say what actually causes the freeze from a distance. The safe bet would be to first upgrade to Ranorex 8.1.1 and then only change the setting if you still experience the freeze.

AFAIK this Windows bug is still not fixed on the latest Windows service release, but it is fixed in the recent Windows insider builds (on the "Fast ring").

Regards,
Alex
Ranorex Team