Automation helper: Failer to send email

Ask general questions here.
rsudhak
Posts: 72
Joined: Fri Jan 04, 2019 1:38 pm

Automation helper: Failer to send email

Post by rsudhak » Thu Jun 13, 2019 10:39 am

Hi I am trying to use the email module from automation helper to send report after the test run using gmail .

I am getting the following error:
Email Error: System.Net.Mail.SmtpException: The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.5.1 Authentication Required. Learn more at
at System.Net.Mail.MailCommand.CheckResponse(SmtpStatusCode statusCode, String response)
at System.Net.Mail.MailCommand.Send(SmtpConnection conn, Byte[] command, MailAddress from, Boolean allowUnicode)
at System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients, String deliveryNotify, Boolean allowUnicode, SmtpFailedRecipientException& exception)
at System.Net.Mail.SmtpClient.Send(MailMessage message)
at Ranorex.AutomationHelpers.UserCodeCollections.EmailLibrary.SendEmail(String subject, String to, String from, String body, String[] attachments, String serverHostname, Int32 serverPort, Boolean useSSL, String username, String password) in

Any idea , how this could be resolved

rsudhak
Posts: 72
Joined: Fri Jan 04, 2019 1:38 pm

Re: Automation helper: Failer to send email

Post by rsudhak » Thu Jun 13, 2019 10:56 am

Resolved, needed to configure app password.... But now my email send but test report not attached