Automation Helpers and Antivirus

Ask general questions here.
User avatar
giuseppe.lacagnina
Posts: 113
Joined: Fri Sep 18, 2015 10:25 am
Location: Brunn am Gebirge, Vienna, Austria

Automation Helpers and Antivirus

Post by giuseppe.lacagnina » Mon Jan 08, 2018 8:53 am

Dear All,

I have an issue with the installation of Automation Helpers in Ranorex 8.0.
My company is using a F-Secure antivirus software.
At the installation, I get a popover from the antivirus claiming that two trojans have been removed.
Before contacting the administrators, I would like to understand a little bit more on the issue.
Did anyone experience that? Any thoughts?

Thanks!

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Automation Helpers and Antivirus

Post by krstcs » Mon Jan 08, 2018 2:50 pm

It's a false positive. Some anti-virus (AV) programs do not recognize Ranorex for what it actually is. Because of some of the low-level actions Ranorex can take, any AV that doesn't have Ranorex already white-listed will think it's a trojan.

You can add those two files to the white-list and try installing again. If it still doesn't work, you will need to disable the AV software.
Shortcuts usually aren't...

User avatar
giuseppe.lacagnina
Posts: 113
Joined: Fri Sep 18, 2015 10:25 am
Location: Brunn am Gebirge, Vienna, Austria

Re: Automation Helpers and Antivirus

Post by giuseppe.lacagnina » Mon Jan 08, 2018 3:17 pm

I actually found that the "infection" files have a .tmp extension. Ranorex, furthermore, claims success.
I will try to see if the extensions work and, if not, will contact the administrator to do the whitelisting.
Thanks!

Giuseppe