AxImp.exe" was not found

Ask general questions here.
mohan.pentyala
Posts: 29
Joined: Thu Sep 20, 2018 7:43 am

AxImp.exe" was not found

Post by mohan.pentyala » Mon Dec 10, 2018 1:15 pm

Hi Team,

I am getting below error while running my solution, I have tried a couple of approaches from blogs but didn't work out.Can you please help me to resolve it

Error :
Task failed because "AxImp.exe" was not found, or the correct Microsoft Windows SDK is not installed. The task is looking for "AxImp.exe" in the "bin" subdirectory beneath the location specified in the InstallationFolder value of the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SDKs\Windows\v8.0A\WinSDK-NetFx40Tools-x86. You may be able to solve the problem by doing one of the following: 1) Install the Microsoft Windows SDK. 2) Install Visual Studio 2010. 3) Manually set the above registry key to the correct location. 4) Pass the correct location into the "ToolPath" parameter of the task. (MSB3091)

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 5061
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: AxImp.exe" was not found

Post by odklizec » Mon Dec 10, 2018 1:22 pm

Hi,

This problem has already been discussed here:
task-failed-because-aximp-exe-was-not-f ... 12848.html
It's most probably a .Net/VS/Win SDK installation issue.

If none of the suggestions work for you, I would suggest you to contact Ranorex support, via their support form available here:
https://www.ranorex.com/support-query/
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration