Azure DevOps Visual Studio and Agent Requirements?

Ask general questions here.
Fergal
Certified Professional
Certified Professional
Posts: 333
Joined: Tue Feb 18, 2014 2:14 pm
Location: Co Louth, Ireland
Contact:

Azure DevOps Visual Studio and Agent Requirements?

Post by Fergal » Fri Jan 31, 2020 12:48 pm

We are setting up a Pipeline in Azure DevOps to run Ranorex (9.1.2) tests on a Windows 10 VM?

From the user guide:
Pipelines in Azure DevOps rely on Microsoft Visual Studio to build Ranorex Studio solutions. You therefore need to have Microsoft Visual Studio installed
Does every VM, which runs tests triggered by an Azure DevOps Pipeline, need to have Microsoft Visual Studio installed on that machine? I ask because I'm not sure if Visual Studio is needed on the VMs where the Ranorex tests are run or if Visual Studio is only needed on the Azure DevOps server.

The VM we wish to run the tests on, has an Azure Pipelines Agent installed, which is connected to Azure DevOps. The Pipeline has been set up on Azure and when that pipeline is run it gives the error message below;
No agent found in pool [Pool Name] which satisfies the specified demands: msbuild visualstudio vstest Agent.Version -gtVersion 2.115.0
Should that error be resolved by installing Visual Studio on the VM, or is it an indication that there is something amiss with the Pipeline or Agent configurations?

Thanks!

McTurtle
Posts: 297
Joined: Thu Feb 23, 2017 10:37 am
Location: Benedikt, Slovenia

Re: Azure DevOps Visual Studio and Agent Requirements?

Post by McTurtle » Mon Feb 03, 2020 1:10 pm

Hello Fergal,

It says in the error... MsBuild, Visual Studio, VS Test... You can just install Visual Studio Community edition, it will cover everything. I'm not saying there is no way to get around this, personally I have not tried. But why risk future issues if installing VS community addition is so easy and does not cost you anything?

Regards,
McTurtle

Fergal
Certified Professional
Certified Professional
Posts: 333
Joined: Tue Feb 18, 2014 2:14 pm
Location: Co Louth, Ireland
Contact:

Re: Azure DevOps Visual Studio and Agent Requirements?

Post by Fergal » Mon Feb 03, 2020 4:00 pm

Thanks very much McTurtle, installing Visual Studio (Community edition) on the VM and then restarting the VM resolved the issue.