Beginner´s issues?

Ask general questions here.
AlexxRR
Posts: 8
Joined: Tue Apr 13, 2021 10:16 am

Beginner´s issues?

Post by AlexxRR » Tue Apr 13, 2021 2:50 pm

Hi everyone,

now that my heart rate got down a bit, I´ll try to explain my issues is a more consistent way.
I´m new in the company, but worked already a few years in testing elsewhere.

I´m using a Lenovo laptop with 2 more Eizo monitors an Windows 10.
I installed today Ranorex 9 for the very first time and I´m experiencing disconcerting issues.

First one:
the font size in the middle pane is way to small, to the point that one would need a microscope.
Second one:
starting a recording, a red-bordered box appear in the 15" laptop´s screen, no matter on which screen Ranorex or the target program is running. Now I´m not able to get the mouse pointer outside the laptop´s screen and thus not able to even reach the target program window. The only way out is to kill Ranorex and after that things get back to normal.

Anyone already experienced anything similar and can help me out?
My only tester colleague is not experiencing anything close to that, but he´s using a desktop PC with just two monitors.

Thanks in advance.
Alex

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6544
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Beginner´s issues?

Post by odklizec » Tue Apr 13, 2021 10:16 pm

Hi Alex,

I guess the problem is caused by high resolution display? Please read this discussion:
spy-top-panel-hardly-usable-on-high-res ... t8814.html

Basically, you need to disable display scaling on high DPI settings. Eventually, you will have to reduce display scaling to max 125%. Anything higher will make the Ranorex Studio font and Spy tracking useless.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

AlexxRR
Posts: 8
Joined: Tue Apr 13, 2021 10:16 am

Re: Beginner´s issues?

Post by AlexxRR » Wed Apr 14, 2021 7:00 am

Thanks a lot.

In my case the .exe´s compatibility settings look a bit different (please see attachment, left your screen shot, right my dialogues) but in the end I could fix it.
Attachments
Ranorex 2.png
Ranorex 2.png (156.15 KiB) Viewed 111 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6544
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Beginner´s issues?

Post by odklizec » Wed Apr 14, 2021 7:02 am

Hi,

Yes, appearance of these settings change between windows versions ;) But it's great to hear you found the right one and I assume it fixed your problem?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration