Browser Hangged - shows "URL" not responding

Experiences, small talk, and other automation gossip.
Luvs1015
Posts: 1
Joined: Thu Apr 07, 2016 5:06 am

Browser Hangged - shows "URL" not responding

Post by Luvs1015 » Mon Apr 11, 2016 10:31 am

Hi Ranorex Support Team,

We have a Ranorex test suite that runs every 3AM (triggered by Jenkins) and it contains more than 30 test cases. As it runs at 3AM nobody is watching it while it run and we been encountering not responding issue but the problem is the issue not happening to specific test case.

Also, during weekend it supposed to run as scheduled but most of time Saturday morning encountered the “not responding” issue so when I checked in Monday morning that’s the time I know that I have nothing to analyse.

What we want to have is if a certain jobs hangs for an allowable waiting time we want to kill it and continue to next step.

I have two questions to address here:
1. Would that be possible given that it is not happening to specific test case (random - maybe generic checking logic in the test suite parent level)?
2. In case the situation change and error will be focused one test case, how to deal with it?

Regards,
Luvs1015
Attachments
NotRespondingError.JPG
NotRespondingError.JPG (104.37 KiB) Viewed 777 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11710
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Browser Hangged - shows "URL" not responding

Post by Support Team » Tue Apr 12, 2016 1:50 pm

Hi Luvs,

I am afraid we would need more information about this issue to figure out what exactly happens.
May I ask you to send me a compressed copy of your solution and a snapshot of your website to [email protected]

This allows me to analyze the behavior in my environment.
Thank you in advance.

Kind regards,
Matthias
.
Image