Bug: Ranorex Spy causes fatal crash of Ranorex Studio

Bug reports.
jsmith
Posts: 28
Joined: Mon Mar 05, 2018 4:03 pm

Bug: Ranorex Spy causes fatal crash of Ranorex Studio

Post by jsmith » Tue Apr 24, 2018 3:04 pm

When using Spy to identify application elements, Spy crashes Studio totally. 2 min video here:
https://John-apteco.tinytake.com/sf/MjU ... 83NjUzNDI5

where do we formally advise RX of bugs??

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3922
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Bug: Ranorex Spy causes fatal crash of Ranorex Studio

Post by odklizec » Wed Apr 25, 2018 8:47 am

Hi,

Unfortunately, it's impossible to tell what's wrong without examining your AUT and test environment. Just some thoughts..

Have you tried to reproduce the problem with Spy started outside the Studio (ideally both 32 and 64bit version)?
Do I see it right that you are trying to track something in Chrome? What's the version of Ranorex plugin installed in Chrome?
Does it happen with just this one specific page/element or you can reproduce it for example with Ranorex page?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

jsmith
Posts: 28
Joined: Mon Mar 05, 2018 4:03 pm

Re: Bug: Ranorex Spy causes fatal crash of Ranorex Studio

Post by jsmith » Wed Apr 25, 2018 10:58 am

Hello, and thank you for your quick reply.

The application on test is a desktop application. Whilst Chrome was open ( and usually is ), the element I was trying to track is in the desktop app, not Chrome. I have never opened Spy outside of Studio... :shock:
I always open it once I am in the recording whose repository I wish to add the item to, otherwise I will have spent time and effort finding the ite, only to not be able to add it to the repo I want??

The application elements are deeply nested, and I have read that this can cause issues. However, I would expect Spy to be able to manage with this, and in any case, the application would need re-writing from the ground up to do it any other way. If Spy can't find the element, then we can't use Ranorex.
I spent two hours yesterday trying to track the element. I drilled down and finally found it, went up one level and came back down to be sure the red box was on the correct element and.....Crash, Ranorex has stopped working. This has stopped test authoring until I can find a solution!

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3922
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Bug: Ranorex Spy causes fatal crash of Ranorex Studio

Post by odklizec » Wed Apr 25, 2018 11:08 am

OK, so I was confused by the Chrome opened in background.

Anyway, I would suggest to try to reproduce the problem with externally opened Spy, especially the 64bit one. The one started from Studio is 32bit. I believe that 64bit spy could better handle too deep structure of UI elements.

Unfortunately, there is not much anyone here (or Ranorex support) can do without access to your app. I would suggest to start an official support ticket (here) and request remote session with Ranorex support folks. This is probably the only way to solve your problem.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration