Build error

Ask general questions here.
Johann
Posts: 17
Joined: Fri May 03, 2019 8:55 am

Build error

Post by Johann » Fri May 03, 2019 9:46 am

Hi i've got a Problem,

i have tried to remove the message because of the detection of WPF elements, according to the tips in forum.
So I uninstalled Ranorex, then uninstalled the 3.5 and 4.5 .NET framework.
Then I installed .NET 3.5 and 4.5 first and Ranorex 9.0 and 9.0.1 at the end.

Since then, the same test in my Solution is always started in my test-suit, no matter what I choose.

So I created a new Sollution for test purposes.
Recorded a new recording and I can't even start it.
The FolderSolution\Test\bin\Debug\ is contai only Ranorex.rxsettings.

Here are the Messages i got while build solution:

Build:
Build started.
Build failed. (00:00:00.1935452)

Packages:
"D:\Program Files (x86)\Ranorex\Studio\Bin\AddIns\Misc\PackageManagement\NuGet.exe" restore "MyTest1.sln"
MSBuild auto-detection: using msbuild version '14.0' from 'C:\Program Files (x86)\MSBuild\14.0\bin\amd64'.
Nothing to do. None of the projects in this solution specify any packages for NuGet to restore.

My system on a VM:
Windows Server 2016
Ranorex 9.0.1

Johann
Posts: 17
Joined: Fri May 03, 2019 8:55 am

Re: Build error

Post by Johann » Tue May 07, 2019 10:11 am

I have fixed the problem, .NET should be installed correctly.

kenlacrosse
Posts: 1
Joined: Mon Jun 03, 2019 7:58 pm

Re: Build error

Post by kenlacrosse » Tue Jun 04, 2019 8:39 pm

I'm seeing the same behavior. How did you install .Net "correctly"?

riagarwal
Posts: 8
Joined: Thu Aug 27, 2015 3:44 pm

Re: Build error

Post by riagarwal » Wed Jun 05, 2019 6:56 pm

Please confirm, how did you resolve the issue. I am also getting the same issue in 9.1.0

User avatar
RobinHood42
Posts: 302
Joined: Fri Jan 09, 2015 3:24 pm

Re: Build error

Post by RobinHood42 » Thu Jun 06, 2019 8:25 am

Hi,

I would suggest updating to Ranorex 9.1. Please just use the Ranorex setup executable and all required prerequisites will be installed - including the .NET framework 4.6.2.

In case you want to install it manually, here you find the correct version: https://www.microsoft.com/en-us/downloa ... x?id=53321

Cheers,
Robin :mrgreen:

vincentxx
Posts: 1
Joined: Wed Jun 05, 2019 8:08 am

Re: Build error

Post by vincentxx » Thu Jun 06, 2019 8:33 am

thanks robin, that fixed it for me. :)