Button identification problem

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
Sourov19
Posts: 1
Joined: Wed Aug 31, 2016 7:40 am

Button identification problem

Post by Sourov19 » Wed Aug 31, 2016 10:48 am

Hello
I am trying to automate one of our Windows application named CatiaV6. Ranorex spy can detect many buttons, but can't detect some. Buttons & text fields of following pictures can't be detected. Could you say what may be the reason?
Attachments
Capture.JPG
Capture.JPG (17.6 KiB) Viewed 675 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3930
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Button identification problem

Post by odklizec » Wed Aug 31, 2016 12:07 pm

Hi,

There is unfortunately not enough info in your post to provide a reasonable answer. Please answer the following questions:
Ranorex version?
Please upload a Ranorex snapshot (not screenshot!) of the problematic elements (or nearest parent element, containing the problematic element).

Generally speaking (from my previous experience with Catia), Catia is based of Dassault's own GUI framework with very little (if any) accessibility support. And I'm afraid, there is no special Catia GUI support built in Ranorex. What you can use is screenshot-based automation.

Another possibility is to extend the Catia window with custom accessibility layer (as we did it in my previous work). But it would require a deep understanding of programming techniques like subclassing. Please follow my post here:
http://www.ranorex.com/forum/ranorex-fo ... tml#p37037
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration