Button presses on mobile app not always recording

Mobile Testing, Android App Testing.
jimmyfinnerty
Posts: 8
Joined: Tue Dec 22, 2015 11:17 am

Button presses on mobile app not always recording

Post by jimmyfinnerty » Wed May 04, 2016 11:55 am

Hi
I am recording tests on an app I have properly instrumented with Ranorex.
The problem I am having is that sometimes the actions I am trying to record, button presses etc are not being reflected in the actions area of the Ranorex recording.
So I press a button on the app and I dont see any reference to it in the Ranorex recording.
This behavior is inconsistent as other times I am able to record thew same button press.
At this point we are wondering if it is a computer performance issue.
My computers processor is an INTEL(R) CORE(TM) i3-4010U CPU 1.70GHz and has recently had its RAM updated from 4.0 GB to 16GB
I am using Ranorex 5.4.6 and the most recent version of Rx Browser.
Ranorex service 1.8.3.
The phone is running Android 5.0.2

Thanks in advance for any help with this issue.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Button presses on mobile app not always recording

Post by Support Team » Fri May 06, 2016 1:26 pm

Hi jimmyfinnerty,

Unfortunately it is hard to analyze this problem without seeing it. Therefore, I'd like to ask you if it would be possible for you to provide us a non-instrumented copy of your application.

You can send the APK to [email protected], if you don't want to post it here in this public forum.

Thank you in advance.
Regards,
Markus (S)
.
Image