Can not see Ranorex generated .html report in Internet Explorer

Ask general questions here.
Ajitpatil3011
Posts: 37
Joined: Thu Aug 22, 2019 4:14 pm

Can not see Ranorex generated .html report in Internet Explorer

Post by Ajitpatil3011 » Thu Feb 13, 2020 7:45 am

Hello,

I have selected the .html report format from the RanorexStudio Test suite properties. but when the report is generated and I try to open them in Internet Explorer I can see blank screen only.
Attachments
Report files.PNG
Report files.PNG (16.11 KiB) Viewed 180 times
Blank screen.PNG
Blank screen.PNG (46.08 KiB) Viewed 180 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6181
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Can not see Ranorex generated .html report in Internet Explorer

Post by odklizec » Thu Feb 13, 2020 8:09 am

Hi,

This is most probably the IE security settings issue. Please follow the steps described in this post:
https://www.ranorex.com/forum/ranorex-r ... tml#p47936
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

Ajitpatil3011
Posts: 37
Joined: Thu Aug 22, 2019 4:14 pm

Re: Can not see Ranorex generated .html report in Internet Explorer

Post by Ajitpatil3011 » Thu Feb 13, 2020 1:52 pm

Hi Pavel,

I tried the same steps, but that does not work out.

Thank you

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6181
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Can not see Ranorex generated .html report in Internet Explorer

Post by odklizec » Thu Feb 13, 2020 2:09 pm

Hi,

Does the report work with other browsers? If yes, then there must be another setting affecting IE? Try to lower the IE security.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

Ajitpatil3011
Posts: 37
Joined: Thu Aug 22, 2019 4:14 pm

Re: Can not see Ranorex generated .html report in Internet Explorer

Post by Ajitpatil3011 » Tue Feb 18, 2020 7:50 am

No, It does not work with any browser.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6181
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Can not see Ranorex generated .html report in Internet Explorer

Post by odklizec » Tue Feb 18, 2020 8:42 am

Hi,

In this case, it sounds like a corrupted report? Please answer below questions...

Does the same happens with any report you generate with Ranorex?
Does the same happens with newly created project?
What happens if you generate standard rxlog/rxzlog?
Are you using custom report template in your project? If yes, please make sure the report template css and xsl files are updated with with most recent 9.2.1 template files. In case you are using custom report template, you must always check what changed in report templates in new Ranorex version and eventually update custom report template with recent Ranorex changes.
And finally, could you please post a sample report (zipped) so we can check it?

Thanks.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration