Can't see objects in Dynamics Nav

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
berkdulger
Posts: 1
Joined: Tue May 24, 2016 11:25 am

Can't see objects in Dynamics Nav

Post by berkdulger » Tue May 24, 2016 11:29 am

Ranorex can't recognize the objects inside forms in a Dynamics Nav application. It's only possible to click on button by giving coordinates. GDI Object recognition didn't help in deed.

We are using Ranorex 6.0

Could you help us?

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3930
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Can't see objects in Dynamics Nav

Post by odklizec » Thu May 26, 2016 7:26 am

Hi,

Could you please post a Ranorex snapshot (not screenshot!) of the problematic element? Also, which version of Dynamics Nav do you use?

BTW, could you please try to examine the element with Microsoft Inspect tool? If Inspect can see the controls inside the problematic element, then it's most probably a Ranorex issue. If Inspect don't see the controls either, then it's a problem of Dynamic Nav control itself (most probably improperly implemented accessibility).

Please follow this post:
http://www.ranorex.com/forum/how-can-ra ... tml#p37089
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration