Cannot get xpath for element only show when hover to other

Ranorex Spy, Recorder, and Studio.
chienlth1
Posts: 8
Joined: Thu Jun 09, 2016 4:01 pm

Cannot get xpath for element only show when hover to other

Post by chienlth1 » Tue Jun 21, 2016 12:31 pm

Hi support team,

We are testing some application on windows 10 using Ranorex 6.0
We cannot get xpath of some elements which only display when you hover or click to other elements.
Example:
We have to get xpath of "Project" element in Action center.

We have many items same as example.
Could you please give me an suggestion.
THanks

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3930
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Cannot get xpath for element only show when hover to other

Post by odklizec » Tue Jun 21, 2016 1:00 pm

Hi,

For such elements, it's best to use "Instant Tracking" feature, as described here:
http://www.ranorex.com/support/user-gui ... html#c3181
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

chienlth1
Posts: 8
Joined: Thu Jun 09, 2016 4:01 pm

Re: Cannot get xpath for element only show when hover to other

Post by chienlth1 » Wed Jun 22, 2016 5:17 am

Thank you for your answer
Now we saw a new issue.
When we recording by ranorex studio to open "Action Center" and click to "project" menu in windows 10.
after that, we re-run recording file, all steps run ok but when we run by exe file, the tool cannot get "Project" menu

Could you let me know the reason?