Cannot use Ranorex-Library when plattform = .Net 4.0

Ranorex Spy, Recorder, and Studio.
AlexDozer
Posts: 33
Joined: Wed Sep 09, 2009 5:41 pm

Cannot use Ranorex-Library when plattform = .Net 4.0

Post by AlexDozer » Mon Sep 19, 2011 11:01 am

Hello,

i have the problem that when I compile the solution with .Net 4.0 I get a exception from the Ranorex-Library.

I have two projects, in one project an exception is thrown when I use the repository. The message of the exception is: Failed to load default plugins. Please reinstall Ranorex. But Ranorex is fresh installed!

In the other project the exception is thrown directly after the start when I set the AbortKey. The message is:

Code: Select all

System.IO.FileLoadException: Mixed mode assembly is built against version 'v2.0.50727' of the runtime and cannot be loaded in the 4.0 runtime without additional configuration information.
   at Ranorex.Keyboard.add_KeyDown
   at Ranorex.Keyboard.set_AbortKey
   at Siemens.SAT.Quality.SQMain.Main in w:\WorkspaceSW3\Tools\TestEngine4.0\TestEngine\SQMain.cs:line 42
On my old computer, where Ranorex 2.x and 3.1 were installed, this problem has not occured. Any solution?

Regards, Alex

AlexDozer
Posts: 33
Joined: Wed Sep 09, 2009 5:41 pm

Re: Cannot use Ranorex-Library when plattform = .Net 4.0

Post by AlexDozer » Mon Sep 19, 2011 1:04 pm

It is possible that I have also to install .Net 3.5 for the mixed mode assemblies from Ranorex? Currently, I have only .Net 4.0 installed.

Regards, Alex

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Cannot use Ranorex-Library when plattform = .Net 4.0

Post by Support Team » Mon Sep 19, 2011 1:09 pm

Hi,

It seems that one of your projects have no app.config file. Therefore please take a look to following troubleshooting documentation http://www.ranorex.com/support/user-gui ... html#c3250

Which version of .Net 40 is installed on your machine? The full one or only the client profile.

Regards,
Peter
Ranorex Team
.
Image

AlexDozer
Posts: 33
Joined: Wed Sep 09, 2009 5:41 pm

Re: Cannot use Ranorex-Library when plattform = .Net 4.0

Post by AlexDozer » Mon Sep 19, 2011 1:33 pm

Hi,

thank you! The missing app.config was the problem.

Regards, Alex