Cant start Test Case

Ranorex Spy, Recorder, and Studio.
imam23
Posts: 1
Joined: Thu Sep 17, 2015 2:10 pm

Cant start Test Case

Post by imam23 » Thu Sep 17, 2015 2:19 pm

Can not intercept exception. Debugged program can not be continued and properties can not be evaluated for :
System.TypeInitializationException: The type initializer for 'SI_Automation.Modules.Basic_Functions.Basic_Functions_Check_AllItemsAdministration'
threw an exception. ---> Ranorex.ElementNotFoundException: Failed to find item 'SI_AutomationRepository.WorkspaceWindow.LstPermissions'.
---> Ranorex.ElementNotFoundException: No element found for path '/form[@automationid='WorkspaceWindow']/form[@classname='Popup']/?/?/list[@automationid='lstPermissions']'
within 1m.
at Temp5442771.RecordingRunner.Run
at Temp5442771.RecordingRunner.Main


Hello, this is what happens, I have no idea why, as i can see that element and if i run just that user code, it works, but if i try to run test case then it fails with error.
Attachments
2015-09-17_1518ranorex1.png
2015-09-17_1518ranorex1.png (6.67 KiB) Viewed 643 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Cant start Test Case

Post by Support Team » Mon Sep 21, 2015 2:23 pm

Hi imam23,

Unfortunately I'd need additional information to analyze your issue in more detail.
May I ask you if it is possible for you to upload your Ranorex Solution?
Please also let me know which version of Ranorex you are currently using?
Thank you in advance.

P.S.: If you do not want to upload your Solution to this public forum, you can also send the file to [email protected]

Regards,
Markus (S)
.
Image