Changing and Saving Properties Does not take effect

Bug reports.
atam
Posts: 15
Joined: Wed Jan 16, 2013 2:58 pm
Contact:

Changing and Saving Properties Does not take effect

Post by atam » Thu Nov 21, 2013 2:36 pm

Hi,

We use image based recognition validation. When uploading to our CI server, we noticed that things started to fail.

After investigation, we realized that the similarity we had set to 90% was set to 100% as default.

We have one test case module:

1. Recording 1: Validates Screenshot1

2. Recording 2: Validates Screenshot2

3. Recording 3: Validates Screenshot3

We changed both global similarity and also for each recording, double checked that similarity was indeed set to 0.9.

BUT, when going into the .cs and .rxrec for Recording 2 and 3, we notice that the default is used (1). Recording 1 is OK though.

Our workaround for this is to manually edit the .rxrec in notepad++ for recording 2 and 3 in order to apply similarity 0.9.

EDIT: We use latest Ranorex.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11710
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Changing and Saving Properties Does not take effect

Post by Support Team » Fri Nov 22, 2013 4:35 pm

Hello atam,

Please note that the setting for similarity in the 'Imaging' tab only affects new valdiations.
Did you change the similarity in each action in your recording module (in 'properties > Image Base Location > Similarity'? This should update the setting in your <Recording>.rxrec.

Did you try to change the similarity value in <Recording>.cs?
Please note that this setting will be overwritten at compile time.

Regards,
Markus (T)
.
Image

MarkF
Posts: 10
Joined: Fri Jan 29, 2016 3:31 pm

Re: Changing and Saving Properties Does not take effect

Post by MarkF » Fri Jan 29, 2016 3:35 pm

Support Team wrote: Did you change the similarity in each action in your recording module (in 'properties > Image Base Location > Similarity'? This should update the setting in your <Recording>.rxrec.
I understand this is a bit old and thus could be out of date (I'm using 5.4.2), but can you elaborate on this? I'm trying to change the 'Similarity' setting, but can't see any 'Image Base Location' setting/menu item when viewing the properties for an action in the recording module.

User avatar
RobinHood42
Posts: 240
Joined: Fri Jan 09, 2015 3:24 pm

Re: Changing and Saving Properties Does not take effect

Post by RobinHood42 » Wed Feb 03, 2016 1:41 pm

Hi MarkF,

Yes, the post is really quite old, but the setting does still exist.
Similarity.png
Similarity.png (15.4 KiB) Viewed 656 times
Please note that the activity must be an "Contains"- or "Compare"-Image activity.

Cheers,
Robin

MarkF
Posts: 10
Joined: Fri Jan 29, 2016 3:31 pm

Re: Changing and Saving Properties Does not take effect

Post by MarkF » Fri Feb 05, 2016 12:49 pm

Ah, I missed the small arrow to the left of 'Image Based' property... :(

Cheers for the info!