Checkboxes and cells not found

Ask general questions here.
Ahmad
Posts: 17
Joined: Tue Apr 09, 2019 7:29 am
Location: Berlin

Checkboxes and cells not found

Post by Ahmad » Wed Jul 10, 2019 2:37 pm

Hi all,

I am working with table and checkboxes inside this table.
The Ranorex doesn't find these checkboxes,
but it finds the cells, that have the checkboxes, only in the first time, when the table opend, but after one click it can not find the cells any more.

I tried with WpfImprovedOnly and Uia configurations, but they give the same result.

Do you have any idea why this happens.

In the appendix you will find a snapshot for the two situation.
Ranorex version: 9.1

Thank you in advance for your support.

Regards,
Ahmad
Attachments
Options_2.rxsnp
(911.53 KiB) Downloaded 6 times
Options_1.rxsnp
(912.07 KiB) Downloaded 9 times
Last edited by Ahmad on Wed Jul 10, 2019 2:39 pm, edited 1 time in total.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 5071
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Checkboxes and cells not found

Post by odklizec » Thu Jul 11, 2019 8:52 am

Hi,

I think it does not matter the checkboxes are not exactly identified. As I see in the snapshots you provided, the cells containing checkbox actually acts like checkboxes! So you can identify proper cells (checkboxes) by cell's Accessible Name and if you want to validate if the checkbox is checked or not, you should use attribute Text of each cell, which contains info regarding check state (gewählt/nicht gewählt). And I'm sure that if you click in the middle of given cell, the click will change the state of checkbox as well? Unfortunately, without seeing your app under test, I can't comment the problem with cells visibility after first click.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

Ahmad
Posts: 17
Joined: Tue Apr 09, 2019 7:29 am
Location: Berlin

Re: Checkboxes and cells not found

Post by Ahmad » Thu Jul 11, 2019 9:44 am

odklizec wrote:
Thu Jul 11, 2019 8:52 am
Hi,

I think it does not matter the checkboxes are not exactly identified. As I see in the snapshots you provided, the cells containing checkbox actually acts like checkboxes! So you can identify proper cells (checkboxes) by cell's Accessible Name and if you want to validate if the checkbox is checked or not, you should use attribute Text of each cell, which contains info regarding check state (gewählt/nicht gewählt). And I'm sure that if you click in the middle of given cell, the click will change the state of checkbox as well? Unfortunately, without seeing your app under test, I can't comment the problem with cells visibility after first click.
Hi,

thank you for your reply.
actually I am working now with cells as checkboxes and I have no problem with them.
And as you said, when I click in the center of the cell, the click will change the state of checkbox. and for the validation I used the attribute "Text".
The problem is only with the visibility of the cells after first click ( as you have seen in the snapshot ).
Currently I am using the click with position in the general table until I find a solution for this issue.

Thank you again for your help and your support.

Regards,
Ahmad

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 5071
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Checkboxes and cells not found

Post by odklizec » Thu Jul 11, 2019 10:36 am

Hi,

Have you tried to set focus on given table (via Invoke Action >> Focus)?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration