Chrome 56 disable session crashed bubble

Ask general questions here.
sorina
Posts: 4
Joined: Tue Jan 10, 2017 1:36 pm

Chrome 56 disable session crashed bubble

Post by sorina » Wed Feb 08, 2017 9:18 am

Hi all,
I run my tests over several browsers and in the browser parameters I had set "-disable-session-crashed-bubble" to avoid failed tests due to the crashed pop-up in Chrome.
However, since a few days with Chrome 56 I noticed that I don't have the yellow line for crash notification, but again a pop-up in the upper right corner of the browser. Do you have any idea of how to get rid of that so that I don't run into failed test cases for that reason?

Many thanks!

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3948
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Chrome 56 disable session crashed bubble

Post by odklizec » Wed Feb 08, 2017 10:26 am

Hi,

I'm not familiar with this popup, but you may be able to handle it with "Handling unexpected Dialogs" code, as described here:
http://www.ranorex.com/support/user-gui ... html#c4678

Otherwise, I would suggest to consult the problem with not working -disable-session-crashed-bubble switch with Chrome support.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Chrome 56 disable session crashed bubble

Post by krstcs » Wed Feb 08, 2017 2:17 pm

Yeah, that's a Chrome issue, not a Ranorex issue. You should contact Chrome support.
Shortcuts usually aren't...

Ethan
Posts: 2
Joined: Mon Aug 08, 2016 12:09 pm

Re: Chrome 56 disable session crashed bubble

Post by Ethan » Fri Feb 10, 2017 10:36 am

I have the same issue since a few days back, if you find a solution for this it would be great if you updated this thread with it.

This Chrome 'functionallity', and the ability to turn it off in a good way, seems to have been discussed back and forth for years.

Best regards,

sorina
Posts: 4
Joined: Tue Jan 10, 2017 1:36 pm

Re: Chrome 56 disable session crashed bubble

Post by sorina » Wed Feb 15, 2017 3:57 pm

Hi Ethan,

I haven't really found a solution, but a workaround. You could try using --incognito. Just make sure you activate the Ranorex plugin for the incognito mode too. I'll keep this thread updates should I come up with a better idea.

Best regards,
sorina