Chrome error note

Ask general questions here.
SanMan
Posts: 204
Joined: Tue Apr 13, 2010 9:59 am

Chrome error note

Post by SanMan » Mon Dec 17, 2018 2:44 pm

What could problem when getting this notification when running web test on Chrome:
Attachments
chrome.png
chrome.png (9.98 KiB) Viewed 217 times

SanMan
Posts: 204
Joined: Tue Apr 13, 2010 9:59 am

Re: Chrome error note

Post by SanMan » Tue Dec 18, 2018 6:32 am

Should I do something more to get it working:
- installed Agent to VM
- installed Chrome
- installed Ranorex Automation Extension for Chrome

When running web test case, this error notification appears. If OK clicked, test run continues

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 5331
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Chrome error note

Post by odklizec » Tue Dec 18, 2018 8:45 am

Hi,

What happens, if you run Chrome manually? Does this error appear too? Have you tried to uninstall/install extension? And finally, are you running tests on the same windows account as you used for installing Chrome and Ranorex extension? The error is kind of strange, because Chrome extension is installed from chrome store and there should be no need to have installed Ranorex and this particular folder. I just tried to remove that folder from my Ranorex installation directory and Chrome (and Ranorex extension) happily works, without any error.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

SanMan
Posts: 204
Joined: Tue Apr 13, 2010 9:59 am

Re: Chrome error note

Post by SanMan » Tue Dec 18, 2018 10:09 am

What happens, if you run Chrome manually? Does this error appear too?
=> Chrome starts normally without problems

Have you tried to uninstall/install extension?
=> Is it possible to remove the extension from Chrome? When I checked, there was no "Remove" button and there was text "Added by Policy". Is this normal?

This error notification appears when Chrome is "commanded to open by test". If OK clicked, test run continues normally until if browser are commanded to close and reopen.

SanMan
Posts: 204
Joined: Tue Apr 13, 2010 9:59 am

Re: Chrome error note

Post by SanMan » Tue Dec 18, 2018 10:56 am

When I go to Ranorex Automation details > View in Chrome Web Store => there is a button "Remove from Chrome" but nothing happens when clicked this button

User avatar
Support Team
Site Admin
Site Admin
Posts: 12002
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Chrome error note

Post by Support Team » Tue Dec 18, 2018 2:04 pm

Hello everyone,

SanMan contacted us directly and we were able to fix the issue by setting the "Instrument" property of the open browser action to false.

InstrumentProperty.png
InstrumentProperty.png (9.26 KiB) Viewed 186 times
Regards,
Bernhard
.
Image