Chrome extension disappearing?

Bug reports.
dhale
Posts: 34
Joined: Thu Feb 27, 2014 7:33 pm

Chrome extension disappearing?

Post by dhale » Wed Feb 06, 2019 4:55 pm

Oddest thing - I just noticed that the Chrome extension is disappearing on me.
Checked with a coworker and same on his PC which is exact same as my PC

PC details:
Win 10 Enterprise x64 version 1803 build 17134.523 Using Chrome Version 72.0.3626.81
Ranorex studio is configured to start as administrator.
I run the instrumentation wizard, and things work fine.

Just to make sure I wasn't seeing things I did the following:

Closed Chrome - checked task manager to make sure Chrome wasn't running.
Used the Studio instrumentation wizard and Installed the extension to Chrome.
Started Chrome - extension was there.
Rebooted PC
Opened Chrome - extension was there.
Closed Chrome
Opened Ranorex Studio 8.3.2
Opened Chrome again - extension was gone.

We upgraded to 8.3.2 on 1/28/2019 , and I just noticed yesterday that on my PC Chrome extension was gone.
I mostly use IE and that extension seems to be sticking around ok.

At first yesterday when I noticed it, I thought maybe I didn't install it for Chrome.
But then today it was gone again.

Any ideas here?

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 4996
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Chrome extension disappearing?

Post by odklizec » Thu Feb 07, 2019 8:49 am

Hi,

I'm not experiencing extension disappearance, but there is still something wrong with the Chrome extension. I'm regularly getting an instrumentation error, about missing extension, even though the extension is clearly installed? I had to uninstall and re-install the extension back, but couple chrome restarts later, the instrumentation error popped up again and I had to repeat the unistallation/installation process again. I'm too using 8.3.2. Chrome version 72.0.3626.96 (Official Build) (64-bit).
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

dhale
Posts: 34
Joined: Thu Feb 27, 2014 7:33 pm

Re: Chrome extension disappearing?

Post by dhale » Thu Feb 07, 2019 4:48 pm

So yesterday I figured I'd try something just for kicks:

I installed the Ranorex Chrome extension directly from the Chrome Web Store. <-- no idea if this had any effect or not.
I also enabled Developer mode in Chrome. <-- no idea if this had any effect or not.

I just rebooted and the Chrome Ranorex extension is still installed.
I don't know that there is any difference between the Chrome Web Store version of the extension, and the 8.3.2 instrumentation wizard version

And today my Chrome is: Version 72.0.3626.96 (Official Build) (64-bit)

natesun
Posts: 10
Joined: Wed Oct 17, 2018 4:05 pm

Re: Chrome extension disappearing?

Post by natesun » Thu Jul 25, 2019 7:53 pm

Yes, it happens to me all the time now, chrome version 75.0.3770.80. Instead of choosing install, I just directly go to App store and add again, but the part I do not understand is I have added several times never removed it, and it could happen several times per day complaining that I do not have the Ranorex ad-on. :o

User avatar
RobinHood42
Posts: 299
Joined: Fri Jan 09, 2015 3:24 pm

Re: Chrome extension disappearing?

Post by RobinHood42 » Mon Jul 29, 2019 10:11 am

Hey,

Try to disable the "Instrument" flag on the "Open browser" action, once the add-on is correctly installed and running.
  • Click on the "Open browser" action
    Hit F4 or right click -> Properties
    Set "Instrument" to false
Hope this helps :mrgreen:
Robin