Chrome extension problems

Ask general questions here.
SanMan
Posts: 204
Joined: Tue Apr 13, 2010 9:59 am

Chrome extension problems

Post by SanMan » Fri Feb 22, 2019 8:28 am

Ranorex 9 Beta
There is shown this technological warning when using Spy....but not every time
Chrome: Version 72.0.3626.119 (Official Build) (64-bit)

When checked from Chrome, there are installed extensions v 1.2.4 and 1.2.3
There is no "Remove" option

When trying to add extension manually:

Failed to load extension
File
C:\Program Files (x86)\Ranorex\Studio Beta\Ranorex Chrome Extension
Error
Ranorex Automation (extension ID "egdlgaljianpgdlmfijpphbadibfncdm") is blocked by the administrator.
Could not load manifest.

Should I uninstall Chrome totally to get this working again?

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 5074
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Chrome extension problems

Post by odklizec » Fri Feb 22, 2019 8:38 am

Hi,

We discussed a similar (if not the same) problem here:
error-loading-chrome-extension-in-9-0-t ... tml#p52986
Try to uninstall extension using Ranorex instrumentation wizard. There is definitely something wrong with chrome plugin. I had to repeat this uninstall/install process several times.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration