Chrome ignores accessibility arg when using OpenBrowser

Ranorex Spy, Recorder, and Studio.
zivshapirawork
Posts: 62
Joined: Wed Sep 24, 2014 7:47 am
Location: Israel

Chrome ignores accessibility arg when using OpenBrowser

Post by zivshapirawork » Sun Dec 13, 2015 1:47 pm

Hi

I am using the following code to open Chrome browser, with the expectation that the accessibility is on. But in fact it is still off and elements are not found. I believe this is the correct argument for chrome to have the accessibility turned on. Can you please advise?

Code: Select all

Host.Local.OpenBrowser(_someUrl_,"Chrome", " --new-window --force-renderer-accessibility", false, true);
Ranorex 5.4.0

Thanks
Ziv Shapira

Martin
Posts: 152
Joined: Fri Aug 15, 2014 12:24 pm

Re: Chrome ignores accessibility arg when using OpenBrowser

Post by Martin » Wed Dec 16, 2015 8:55 am

zivshapirawork wrote:Hi

I am using the following code to open Chrome browser, with the expectation that the accessibility is on. But in fact it is still off and elements are not found. I believe this is the correct argument for chrome to have the accessibility turned on. Can you please advise?

Code: Select all

Host.Local.OpenBrowser(_someUrl_,"Chrome", " --new-window --force-renderer-accessibility", false, true);
Ranorex 5.4.0

Thanks
Ziv Shapira
I tried some debugging and for me your code worked perfectly. (_someUrl_ was ofcourse "http://www.ranorex.com").

Accessibility was enabled with both browser parameters
Accessibility was enabled with just --force-renderer-accessibility
Accessiblity wasn't enabled when no parameters were sent

From this I believe that the issue might be with Chrome itself. For example there are settings/parameters that can override the --force-renderer-accessibilty and might be configured somewhere in Chrome settings.

Even though you do not sent the "disable-renderer-accessibility" parameter specifically, this is one of the settings that can override the --force-renderer-accessibility and might be turned on somewhere else in Chrome.

I'd try doing a clean Chrome reinstall.

Edit:

As you are sending a --new-window parameter as well, can you confirm that you have actually closed all the previous Chrome windows before opening another one with the parameters.

If any previous Chrome windows are open with Accessibility disabled, it won't be enabled for the new opened window. You have to keep this in mind.