Chrome not registering clicks

Bug reports.
randallmeyer
Posts: 1
Joined: Wed Nov 15, 2017 11:20 pm

Chrome not registering clicks

Post by randallmeyer » Wed Nov 15, 2017 11:22 pm

After a couple of weeks I came back and the scripts don't seem to register any clicks or type in any letters. This is also broken on firefox, but works on IE. Please help me get to the bottom of this.

qwertzu
Posts: 179
Joined: Wed Jan 25, 2017 11:08 am

Re: Chrome not registering clicks

Post by qwertzu » Thu Nov 16, 2017 1:58 pm

hi,
so your test only fails within Firefox and chrome?
you could try to update both browsers to the latest version, delete the RX Atuomation extension and instrument the browsers again. maybe, this will fix it.
What Ranorex version are you currently using?
regards, qertzu

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Chrome not registering clicks

Post by krstcs » Thu Nov 16, 2017 7:02 pm

Sounds like you don't have the correct Ranorex extensions installed. As qwertzu said, try re-instrumenting the browsers. The newest versions of Chrome and FF have a new Ranorex plugin requirement.

Also, please ALWAYS include the following when raising an issue:

1. FULL Ranorex version (currently only 7.1.3 and 7.2.1 are supported)
2. Windows version
3. Technology of system under test (your's appears to be web-based, so HTML, but is it Angular, Asp.net, etc.)
4. Ranorex SNAPSHOT (NOT screenshot!) of element in question, if applicable.
5. RanoreXPath of element in question, if applicable.

These items are required in order to ensure that the help we give is the most relevant and meaningful. Without at least the first two we are basically guessing.
Shortcuts usually aren't...