Chrome problem urgent please help.

Ask general questions here.
rastek
Posts: 157
Joined: Wed Aug 06, 2014 12:00 pm

Chrome problem urgent please help.

Post by rastek » Mon Aug 25, 2014 11:15 am

I am testing an applications that is stable in chrome but not in IE.

I am using Ranorex recordings by importing into GUI tool (without using repository, just with paths)

When running a recording module by itself on a Chrome in Ranorex, objects are correctly identified and actions work.

However, when running the same recording modules in a TestShell GUI module, recording works for IE.

I can not get my recording work in chrome inside TestShell, what can I do it for working ??
Please help needed immediately.

Chrome Version: 36.0.1985.143
Ranorex Version: 5.1
TestShell version: 5.0

Thanks,
Rastek.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Chrome problem urgent please help.

Post by Support Team » Tue Aug 26, 2014 12:35 pm

Hi Rastek,

I am afraid I have no experiences with TestShell, but what error message do you get when you try to execute the Chrome recording?
Where do you execute the tests, on another environment or on your local machine?
Could it be that different users are used for Chrome or that Chrome is not instrumented on the other environment?
Please describe the problems you are experiencing in more detail this will help us in analyzing the issue.

Thanks,
Markus
.
Image

rastek
Posts: 157
Joined: Wed Aug 06, 2014 12:00 pm

Re: Chrome problem urgent please help.

Post by rastek » Sun Aug 31, 2014 10:20 am

My recoding work in Crome if I run from Ranorex or from exe, but when I import into Testshell, it works in IE but not Chrome. There is object recogniton problem.

Another problem is sometime chrome extension is lost. I mean, extension is tehre, but recordings dont work even freom Ranorex or from exe. I need to delete extension and install again.

Are you sure your chrome extension is stable with version 5.1 ?

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Chrome problem urgent please help.

Post by Support Team » Tue Sep 02, 2014 12:32 pm

Hi Rastek,

As I wrote before we have unfortunately little knowledge about Testshell and how the tests get executed with Testshell but could it be that you use different profiles for Chrome?
Did you use the Chrome plugin which can be downloaded from the chrome web store?

With Ranorex 5.1 we introduced the new Chrome Plugin and we are sure that it runs stable, your issue might be related to some security or permissions problems. May I ask you if you have administrative privileges and which OS version you use?
Does this just happen on your machine or on others machines too?
Could you send me the exact error message you are getting when you run the tests with Testshell and Chrome?

Regards,
Markus
.
Image

rastek
Posts: 157
Joined: Wed Aug 06, 2014 12:00 pm

Re: Chrome problem urgent please help.

Post by rastek » Fri Sep 19, 2014 6:53 pm

I do not get any error message, there is no error message. I think it is a version problem. Ranorex 5.1 iş not yet supported with tool I am using, Thanks in advance.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Chrome problem urgent please help.

Post by Support Team » Tue Sep 23, 2014 4:17 pm

Hi Rastek,

May I ask you to send an email to [email protected] to discuss this issue in detail?

Regards,
Markus
.
Image