Code editing lag in solution - Updating module browser

Ask general questions here.
RWitanski
Posts: 7
Joined: Fri Sep 16, 2016 4:10 pm

Code editing lag in solution - Updating module browser

Post by RWitanski » Wed Jan 18, 2017 10:01 am

Hello,

While I edit code modules, user codes or any other code files. Ranorex is getting a freeze for about 1 second
and it informs that the module browser is being updated (see screen below).
Image
After updating is finished it changes state to "Ready" and I can continue coding. This situation occurs every 2~seconds while I enter any code so it's quite frustrating.

Is there any option or fix to solve this issue?

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3930
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Code editing lag in solution - Updating module browser

Post by odklizec » Wed Jan 18, 2017 10:06 am

Hi,

Are you using TFS? I remember problem like this with integrated TFS. The only solution is to stop using integrated source control management and using Team Explorer instead.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

RWitanski
Posts: 7
Joined: Fri Sep 16, 2016 4:10 pm

Re: Code editing lag in solution - Updating module browser

Post by RWitanski » Thu Jan 19, 2017 8:49 am

odklizec wrote:Hi,

Are you using TFS? I remember problem like this with integrated TFS. The only solution is to stop using integrated source control management and using Team Explorer instead.
Do you have any ideas how I can clean any project references to TFS ( I have disabled TFS Option: enable file state 'modified' check.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3930
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Code editing lag in solution - Updating module browser

Post by odklizec » Thu Jan 19, 2017 8:52 am

Hi,

You can do it by Remove Source Control Binding option, as described here:
http://www.ranorex.com/forum/ranorex-oc ... rer#p32130
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

RWitanski
Posts: 7
Joined: Fri Sep 16, 2016 4:10 pm

Re: Code editing lag in solution - Updating module browser

Post by RWitanski » Wed Feb 01, 2017 12:10 pm

I have found the reason of the problem,
After removing some of the modules, we left (about 80) warnings that there is a missing reference in the test module browser. It seems that when we edit the code the module browser is "rebuilding" and while there are missing module references in the module browser it takes few seconds to reload itself. Removing the warning with the missing references solves the problem. From now the issue with the code editing freeze\lag while writing the code do not persist anymore.

Thanks for the help.
Kind Regards,
RW

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Code editing lag in solution - Updating module browser

Post by Support Team » Fri Feb 03, 2017 9:57 am

Hi RW,

Thank you for reporting this behavior.

May I ask you which version of Ranorex you are currently using?
Please also do let me know if we could gain access to your Ranorex project which causes this issue. This would allow us to analyze the problem in more detail.

Thank you in advance.

Regards,
Markus (S)
.
Image