Compatibilty with SVN 1.8

Ask general questions here.
carsonw
Posts: 178
Joined: Tue Nov 08, 2011 10:01 pm

Compatibilty with SVN 1.8

Post by carsonw » Mon Jul 15, 2013 11:39 pm

Hi there, I see Tortoise SVN has moved to 1.8 now (http://tortoisesvn.net/tsvn_1.8_releasenotes.html). Just wondering if Ranorex will properly support it (there are just options for 1.6 & 1.7 in the subversion settings in Ranorex)?

I don't want to experiment and find out the hard way. Thanks :)

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Compatibilty with SVN 1.8

Post by Support Team » Wed Jul 17, 2013 9:05 am

Hi,

Version 1.8 is currently (4.0.5) not supported, but the feature request was already forwarded to our internal system. Please note that there is not yet a release date for that feature.

Regards,
Markus
.
Image

carsonw
Posts: 178
Joined: Tue Nov 08, 2011 10:01 pm

Re: Compatibilty with SVN 1.8

Post by carsonw » Wed Oct 02, 2013 8:13 pm

Hi there - just checking to see if there's an update on this one. Many of our applications use source control, and none of them can be updated until Ranorex catches up. Thanks :)

Carson.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Compatibilty with SVN 1.8

Post by Support Team » Thu Oct 03, 2013 7:53 am

carsonw wrote:Many of our applications use source control, and none of them can be updated until Ranorex catches up
Actually, if you don't need any of the new SVN 1.8 feature, then you can still stick with your SVN 1.7 client software, even if your SVN server is already updated to version 1.8. The client and server versions from SVN 1.5 up are all compatible:
http://subversion.apache.org/docs/relea ... s/1.8.html

Regards,
Alex
Ranorex Team
.
Image

GMail
Posts: 9
Joined: Tue Jul 16, 2013 10:10 pm

Re: Compatibilty with SVN 1.8

Post by GMail » Thu Oct 17, 2013 4:08 pm

Hi,

We are using Ranorex 4.1.0.25227 with TortoiseSVN 1.7.13.24257 x64 with SVN 1.7.10.
We got a message saying the Subversion client version is not compatible with the woprking copy version.

We selected the 1.7 version from Tools menu.

Which SVN client version is compatible with Ranorex 4.1.0 ?
Attachments
2013-10-17 11_00_43-TestSuite_mCAD - Ranorex Studio.png
2013-10-17 11_00_43-TestSuite_mCAD - Ranorex Studio.png (7.23 KiB) Viewed 1447 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Compatibilty with SVN 1.8

Post by Support Team » Fri Oct 18, 2013 11:31 am

Hello GMail,

In general Ranorex supports SVN version 1.6 and 1.7 at the moment.
It should work if you select 1.7 in the Subversion Options dialog.
Have you already read the blog "Source Control" on our website?

Regards,
Bernhard
.
Image