Compile problem with Ranorex 6.0

Ask general questions here.
jackrabbit
Posts: 47
Joined: Wed Mar 18, 2015 10:06 pm

Compile problem with Ranorex 6.0

Post by jackrabbit » Fri Jun 10, 2016 2:55 pm

I was using version 5.3.4 and I am currently testing 6.0 to upgrade my tests solutions.

My solution was compiling using 5.3.4 but no longer compiles in 6.0.0. In the project properties, in the Compiling tab, if I change the Target CPU to 32 bits, it now compiles.

However I do not want a 32 bits version. I want to go 64 bits, but I can only select the platform x86 in this tab page.

What do I need to do to go 64 bits all the way?

2016-06-10_09h44_16.png
2016-06-10_09h44_16.png (521.76 KiB) Viewed 526 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3922
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Compile problem with Ranorex 6.0

Post by odklizec » Fri Jun 10, 2016 3:02 pm

Hi,

Unfortunately, it's no longer possible to debug 64bit apps in Ranorex 6.0. You probably missed this breaking release note:
Due to the underlying SharpDevelop update within Ranorex Studio, debugging of 64bit applications is not supported any more -> choose "32-bit processor" as Target CPU in your test suite project "Compiling" properties
In other words, 64bit Release version should compile just fine.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration