Computer freeze/CPU shoots very high when using Ranorex Spy

Ask general questions here.
c676228
Posts: 176
Joined: Mon Apr 06, 2015 5:40 am

Computer freeze/CPU shoots very high when using Ranorex Spy

Post by c676228 » Tue May 26, 2015 11:34 pm

Hi Folks,

Can you provide insight about what will cause computer freeze or CPU shoots very high when using Ranorex Spy to track UI elements?

Thanks,
Betty

krstcs
Ranorex Guru
Posts: 2683
Joined: Tue Feb 07, 2012 4:14 pm
Location: Austin, Texas, USA

Re: Computer freeze/CPU shoots very high when using Ranorex Spy

Post by krstcs » Wed May 27, 2015 2:23 pm

Without more information about the element in question and the system it will be hard to tell what the problem might be.

Can you post a snapshot of the element that is causing the issue? Is the AUT x86 or x64?

What version of Ranorex are you using?

What version of Windows are you using?

Is there anything else running in the background?
Shortcuts usually aren't...

c676228
Posts: 176
Joined: Mon Apr 06, 2015 5:40 am

Re: Computer freeze/CPU shoots very high when using Ranorex Spy

Post by c676228 » Fri May 29, 2015 1:12 am

Actually I am asking the question for one of my colleagues.
Ranorex/AUT are both installed on VM
Ranorex: version 5.3.2
Windows 8.1x64
Nothing else running
Application is 32 bit

"The issue happens when I have a particular tile (Optional Authentication) open in the application. "

See sep1

"Ranorex is unable to detect it so I use spy to detect the whole desktop, and then I try to find the elements I need manually. Once I try to open “WinApp ‘our product’ in spy, it freezes. If optional Authentication is not open, spy will not freeze."

See sep2
Last edited by c676228 on Tue Jun 02, 2015 6:40 pm, edited 1 time in total.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Computer freeze/CPU shoots very high when using Ranorex Spy

Post by Support Team » Tue Jun 02, 2015 12:57 pm

Hi c676228,

In order to analyze this freezing issue I'd need the Ranorex Log file. To enable the logging mechanism, please rename the attached file to NLog.config and copy the file into the following directories
  • C:\Program Files (x86)\Ranorex 5.3\Bin\x64
  • C:\Program Files (x86)\Ranorex 5.3\Bin
  • C:\Program Files (x86)\Ranorex 5.3\RanorexStudio\bin
After copying the file and reproducing the issue, the log files can be found in C:\Temp.
If you don't want to post the logfiles in this public forum you can also send it to [email protected]

Pleaes note to make a backup of the original NLog.config file.

Regards,
Markus (S)
Attachments
NLog.config.txt
(1.02 KiB) Downloaded 45 times
.
Image