Confusing compilation error

Ask general questions here.
User avatar
sandamal
Posts: 28
Joined: Wed Jul 08, 2015 7:50 am

Confusing compilation error

Post by sandamal » Wed Dec 07, 2016 6:25 am

Hi Guys,

I created a record module for get a text from an element. and create a module variable and assign that text.

then I convert that to a User code , inside code I almost re-write the code, Did not use that previously created variable.

and things ran well as expected.

later on since im not using that created variable (it was showing as a unbound variable) I deleted it via Variables window.

Now it is giving a compilation error. im unable to find any reference for that variable within the code too.

can some expert make a suggestion to resolve this.

and ranorex is just giving a general error on compile error . :|

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3930
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Confusing compilation error

Post by odklizec » Wed Dec 07, 2016 8:23 am

Hi,

Have you searched for the presence of given variable name in all solution files (e.g. using an external file editor)? Maybe there is still some reference hidden somewhere in the project files? ;) I believe I've experienced such issue once or twice in the past.

Eventually, try to remove the module you modified from the solution. Maybe there is a code error, which is causing the compilation problem and the fact it started after removing the variable is just a coincidence? ;)
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration