Control not indentify in my local machine but able to do in VM

Ask general questions here.
auro
Posts: 1
Joined: Mon Oct 29, 2018 1:08 pm

Control not indentify in my local machine but able to do in VM

Post by auro » Mon Oct 29, 2018 1:13 pm

controls are able to identify through heighlight and but during running its not
I have checked controol is not generating any dynamic property.
Same if i am running through my VM its work perfectly.
Than why issue in my local machine not able to understand.In local machine heighlight working but while trying to run un test suite its not .But i am running same test suites in VM its is working.
I am using ranorex 8 .Pleasse help on quick

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 3930
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Control not indentify in my local machine but able to do in VM

Post by odklizec » Tue Oct 30, 2018 8:50 am

Hi,

If Ranorex is able to track the element on VM and not on your physical machine, then there must be something different on that machine. Please answer below questions...

Are you sure Ranores settings are the same on both machines? Different settings are a most common cause of problems like this.
What technology are we talking about (c++, java, mfc, delphi, web-based,...)?
What OS do you use on both machines?
Are you sure both machines use the same version of .Net and VC++ runtime libs?
And finally, please upload a Ranorex snapshot (NOT screenshot) of your app, ideally, taken on both machines so we can see the difference.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration