Could not be uniquely identifying object using id/name

Ask general questions here.
praneet
Posts: 28
Joined: Thu Nov 08, 2018 2:22 am

Could not be uniquely identifying object using id/name

Post by praneet » Tue Mar 17, 2020 1:34 pm

I have used id/name for objects identification, even though search object taking more than 2sec and showing yellow exclamatory mark showing
'One element found for current selection. The parent repository folder for this item could not be uniquely identified'. How to make object with unique identification and less search times.
objectSpy.png
objectSpy.png (49.41 KiB) Viewed 160 times
Ranorex Version-9.1.0
OS:WIn7
Browser- IE11

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6190
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Could not be uniquely identifying object using id/name

Post by odklizec » Tue Mar 17, 2020 2:48 pm

Hi,

At first, please update Ranorex to more recent 9.2.1 or 9.3.0. Only these versions are currently supported. 9.1.0 is obsolete.
At next, please upload a Ranorex snapshot (NOT screenshot) of the problematic element and full xpath you are using, so anyone here can review these two critical pieces and eventually, suggest the solution. Without, at very least, a Ranorex snapshot, there is not much anyone here can do or suggest.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration