could not capture label properties using spy

Ranorex Spy, Recorder, and Studio.
palanikumar.m
Posts: 8
Joined: Mon May 19, 2008 2:35 pm

could not capture label properties using spy

Post by palanikumar.m » Tue May 20, 2008 2:55 pm

Hi,

I could not capture the label properties using RanorexSpy.

Is it possible to capture or not?

Plz, help anybody!!!!!

It's very urgent requirement for me.

Thanks & Regards,
Palani

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Post by Support Team » Tue May 20, 2008 5:01 pm

Could you please give us some more information:
What kind of label is it (e.g. .NET, Win32)?
When you drag the RanorexSpy crosshair to the label, do you see a black frame around the label?
Do you mean the property grid on the right side of RanorexSpyPro or the control/element properties displayed by RanorexSpy?

Regards,
Alex
Ranorex Support Team

palanikumar.m
Posts: 8
Joined: Mon May 19, 2008 2:35 pm

could not capture label properties using spy

Post by palanikumar.m » Wed May 21, 2008 11:39 am

Hi Alex,

It is a Win32 Label only.

After run the application, i have tried to find the properties of label using both controls.

But, i could not see the black frame.

Other than label control, i can see that frame.

Even i could not see the black frame, so, i could not see any properties in RanorexSpy or RanorexSpyPro

Regards,
Palani

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Post by Support Team » Mon May 26, 2008 2:16 pm

If RanorexSpy can't find that "control", then it will be quite difficult to automate it, i.e. get information from it. If it's a .NET application, you can try to add some additional test methods to the application as explained in this blog entry.

Could you tell me the application that this label belongs to or send a sample application to support_at_ranorex.com?

Regards,
Alex
Ranorex Support Team