could not find "sgen.exe"

Bug reports.
sozssp
Posts: 2
Joined: Mon Nov 26, 2018 9:44 am

could not find "sgen.exe"

Post by sozssp » Mon Nov 26, 2018 9:48 am

Task could not find "sgen.exe" using the SdkToolsPath "" or the registry key "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SDKs\Windows\v8.0A\WinSDK-NetFx40Tools-x86". Make sure the SdkToolsPath is set and the tool exists in the correct processor specific location under the SdkToolsPath and that the Microsoft Windows SDK is installed (MSB3086)

Other Projects are fine.

Thanks Peter

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 4047
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: could not find "sgen.exe"

Post by odklizec » Mon Nov 26, 2018 11:09 am

Hi,

Are you, by any chance, using web references in the failing project? Check for example this post, with some suggestions how to fix this problem. It’s most probably not a Ranorex issue, but rather a problem with .net/visual studio libs installation.
https://stackoverflow.com/questions/130 ... -not-found
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

sozssp
Posts: 2
Joined: Mon Nov 26, 2018 9:44 am

Re: could not find "sgen.exe"

Post by sozssp » Mon Nov 26, 2018 11:29 am

Hello,
That helped, deleting the web references in the Ranorex Project.

Thanks Peter