'Could not load file or assembly' error when opening any solution

Bug reports.
Darryl
Posts: 3
Joined: Mon Aug 13, 2018 2:40 pm

'Could not load file or assembly' error when opening any solution

Post by Darryl » Mon Aug 13, 2018 2:50 pm

When I first open a solution, including creating a brand new solution, I get the attached error.
Screenshot_24.png
Screenshot_24.png (21.72 KiB) Viewed 217 times
Could not load file or assembly
'Microsoft.TeamFoundation.VersionControl.Client, Version=12.0.0.0.'

When this is dismissed, I get SCC Provider: Nonspecific error.

I can then dismiss the second error, and Ranorex appears to function as expected, but it's a little frustrating getting these errors every time I open a solution. I'm not using TFS at all, it's not installed on my machine.

I started getting this on Ranorex 7.2, but have since upgraded to 8.2.0 and have the same issue.

Ranorex version: 8.2.0+git.10ce4055
Windows version: Windows 10, version 1803 (build 17134.112)

Darryl
Posts: 3
Joined: Mon Aug 13, 2018 2:40 pm

Re: 'Could not load file or assembly' error when opening any solution

Post by Darryl » Thu Aug 16, 2018 11:01 am

Any ideas? I've uninstalled Ranorex, removed all of the AppData/documents/program files folders, and reinstalled 8.2. I still get the same errors when creating a new solution or opening an existing one.

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: 'Could not load file or assembly' error when opening any solution

Post by Support Team » Fri Aug 17, 2018 5:30 am

Hi Darryl,

Thank you for submitting your bug report, I would be happy to help.

There should be more information within the internal logging for Ranorex so I would definitely start there. You can find the Ranorex internal logs at the below location:

Code: Select all

 %userprofile%\Documents\Ranorex\Logs
It is generally recommended to first reproduce the issue before sharing your logs which should be easy to do in this case. We usually just recommend zipping the entire Logs directory for review, but please know there is information within the logs about your test runs. If this is not information you would like to share publically, I would highly recommend creating a support request and reference this post.

Either way, once we can review the internal logs we should have more information. I know you do not use TFS, but do you know if you have ever had the MSSCCI provider installed?

I look forward to hearing from you!

Regards,

Jon
.
Image

Darryl
Posts: 3
Joined: Mon Aug 13, 2018 2:40 pm

Re: 'Could not load file or assembly' error when opening any solution

Post by Darryl » Mon Aug 20, 2018 10:44 am

I've attached the logs. Immediately before zipping these up, I opened Ranorex and created a new solution, so it should be the most recent things in the logs.

It looks like I have previously had the MSSCCI installed as there are, though it isn't installed any longer.
Attachments
ranorexlogs.zip
(385.32 KiB) Downloaded 4 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: 'Could not load file or assembly' error when opening any solution

Post by Support Team » Fri Aug 24, 2018 7:29 am

Hi Darryl,

Thank you for the update.

After reviewing the logs I believe the next best step would be a brief 30-minute remote session. To schedule a session, please create a ticket within our support center and reference this post.

I look forward to hearing from you!

Regards,

Jon
.
Image