CSV file not copied to \bin\debug

Bug reports.
anja
Posts: 67
Joined: Fri Nov 26, 2010 3:39 pm

CSV file not copied to \bin\debug

Post by anja » Fri Apr 08, 2011 8:39 am

Hi,

I've just found another issue... If I add a new CSV file to my solution, I enable the option copy to solution.

This seems to work correctly. If I try to execute the tests following message appears:
Failed to get rows from data source: Failed to read CSV data file: 'filename.csv'. Could not find file '<Path to project>\bin\Debug\filename.csv'

If I look in this folder, the file is not copied there. If I add it manually to this location, the tests run correctly.

To copy it there manually is ok, but if you want to adapt the input data, the file in the bin\Debug folder is not updated.

I even tried to do a clean solution and execute it... the same probleme...
This happens only with some of the .csv files... I do not know exactly what makes the difference because I use everytime I add a .csv file the same actions....

Regards
Anja

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: CSV file not copied to \bin\debug

Post by Support Team » Fri Apr 08, 2011 9:21 am

Hi,

Thank you for posting us this bug. I was able to reproduce it and I already filed a bug.
This fix will be available within the next maintenance release. To overcome this issue at the moment, please select the file inside the Ranorex Project Tree and change the "Copy to output directory" property to Always or PreserveNewest. The setting "Copy to output directory" is available in the properties tab of the file.

Regards,
Peter
Ranorex Team
.
Image

anja
Posts: 67
Joined: Fri Nov 26, 2010 3:39 pm

Re: CSV file not copied to \bin\debug

Post by anja » Fri Apr 08, 2011 10:21 am

thank you for this quick help... this solved the problem at the moment...