Cursor makes strange movements when i record a Test

Ask general questions here.
User avatar
a.bischof
Posts: 3
Joined: Mon Nov 12, 2018 9:48 am
Contact:

Cursor makes strange movements when i record a Test

Post by a.bischof » Mon Nov 12, 2018 10:13 am

Hello dear Ranorex Community and Ranorex Team!

I have the problem that during a test recording the cursor makes strange movements and doesn't really do that what i do with the mouse. Sometimes the cursor stucks on one spot and just trembles in the direction i move the mouse.

This makes recording a test extremly tough.

How can i fix this issue?

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 4041
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Cursor makes strange movements when i record a Test

Post by odklizec » Mon Nov 12, 2018 10:28 am

Hi,

Unfortunately, there is not enough information regarding the problem, to provide a reasonable answer. Please answer below questions...
What OS are you on?
What Ranorex version do you use?
Are you on physical or virtual machine?
What kind of application are you automating (desktop, web, etc...)?
What GUI framework/library uses the app under test?
Have you tried to record test on another PC?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

dugovic.milan
Posts: 41
Joined: Wed Jun 29, 2016 1:19 pm
Location: Frankfurt, Germany
Contact:

Re: Cursor makes strange movements when i record a Test

Post by dugovic.milan » Mon Nov 12, 2018 10:30 am

Hi a.bischof! Can you please mention which Ranorex version you're usinng ATM? Also, you could try to set our scaling down to 100% if that helps. There have been some issues in 8.3 particularly with the recording tool, which are about to get fixed.
Ranorex 8.3.0

User avatar
a.bischof
Posts: 3
Joined: Mon Nov 12, 2018 9:48 am
Contact:

Re: Cursor makes strange movements when i record a Test

Post by a.bischof » Mon Nov 12, 2018 10:59 am

Thanks for the quick responses!

Excuse me for not sharing more informations with you!

What OS are you on?
Windows 10 1809

What Ranorex version do you use?
Ranorex 8.3.0

Are you on physical or virtual machine?
I experience this issue on my physical PC

What kind of application are you automating (desktop, web, etc...)?
I evaluate a desktop application.

What GUI framework/library uses the app under test?
It's a winforms application running on .Net-Framework 4.7.2 with DevExpress UI Elements

Have you tried to record test on another PC?
Yes i did. I connected on a Test PC via TeamViewer and everyting works fine there, but i couldn't figure out why this works, while on my PC it's a pain to work with. Both PCs have exactly the same Hardware.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 4041
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Cursor makes strange movements when i record a Test

Post by odklizec » Mon Nov 12, 2018 11:06 am

a.bischof wrote:
Mon Nov 12, 2018 10:59 am
Have you tried to record test on another PC?
Yes i did. I connected on a Test PC via TeamViewer and everyting works fine there, but i couldn't figure out why this works, while on my PC it's a pain to work with. Both PCs have exactly the same Hardware.
Well, then the problem is most probably in OS/Ranorex settings? Unfortunately, it's hard to tell what's wrong without access to the PC.

What you can try is to change the Ranorex settings (e.g. set the opposite state of some Advanced settings, like Use asynchronous dispatching mouse and keyboard events). If nothing helps, then you will have to contact Ranorex support and request remote session with them, so they can see it in action and eventually suggest something?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

User avatar
a.bischof
Posts: 3
Joined: Mon Nov 12, 2018 9:48 am
Contact:

Re: Cursor makes strange movements when i record a Test

Post by a.bischof » Mon Nov 12, 2018 11:46 am

Thnak you verry much odklizec!

I deactivated the "Use asynchronous dispatching mouse and keyboard events"-option and now it is working perfectly!

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 4041
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Cursor makes strange movements when i record a Test

Post by odklizec » Mon Nov 12, 2018 12:31 pm

Nice to hear that! You are welcome ;)
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration