Custom Grid Control

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
kmr
Posts: 2
Joined: Mon Mar 05, 2012 7:35 am

Custom Grid Control

Post by kmr » Mon Mar 05, 2012 8:36 am

Hi,

we got a custom grid control where the cells are not recognized by Ranorex. We have implemented the AccessibleObject for both Row and Cell but Ranorex is not recognizing the objects.

In Ranorex Spy both AcessibleValue and ScreenRectangle is correct, but "Highlight Element" is not working. What may be the problem?

screenshot from Ranorex:
Attachments
ranorexspy.jpg
ranorexspy.jpg (310.48 KiB) Viewed 1175 times

User avatar
Support Team
Site Admin
Site Admin
Posts: 11709
Joined: Fri Jul 07, 2006 4:30 pm
Location: Graz, Austria

Re: Custom Grid Control

Post by Support Team » Mon Mar 05, 2012 1:59 pm

Hi,
kmr wrote:In Ranorex Spy both AcessibleValue and ScreenRectangle is correct, but "Highlight Element" is not working. What may be the problem?
Does this work if you try to highlight the element via code? Please take a look to following post
http://www.ranorex.com/forum/highlight- ... tml#p10458
In this post you will find how to highlight a element via code.

And please check with your developers if the position of the element will be calculated correctly. According to your screenshot the calculation seems to be wrong, because your element appears on the screen at position 3;25 and this is in the left top corner. Or does the element appear on this position?

Regards,
Peter
Ranorex Team
.
Image

kmr
Posts: 2
Joined: Mon Mar 05, 2012 7:35 am

Re: Custom Grid Control

Post by kmr » Tue Mar 06, 2012 8:41 am

Thanks, yes it seems like the screen position is wrong, we need to investigate this.

/K